Bug 1654736 - doesnt work network after install kernel 4.19.*
Summary: doesnt work network after install kernel 4.19.*
Keywords:
Status: CLOSED DUPLICATE of bug 1650984
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-29 15:00 UTC by valera
Modified: 2018-12-12 14:28 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-12 14:28:47 UTC
Type: Bug


Attachments (Terms of Use)
4.18_journalctl _SYSTEMD_UNIT=NetworkManager.service > NetworkManager.txt (23.79 KB, text/plain)
2018-11-29 15:00 UTC, valera
no flags Details
4.19_journalctl _SYSTEMD_UNIT=NetworkManager.service > NetworkManager.txt (9.48 KB, text/plain)
2018-11-29 15:01 UTC, valera
no flags Details
4.19.6 (71.78 KB, text/plain)
2018-12-04 16:35 UTC, valera
no flags Details
4.19.7 from test repo (69.91 KB, text/plain)
2018-12-07 20:38 UTC, valera
no flags Details
journalctl _SYSTEMD_UNIT=NetworkManager.service (9.51 KB, text/plain)
2018-12-12 09:16 UTC, valera
no flags Details
systemctl status NetworkManager (1.85 KB, application/octet-stream)
2018-12-12 09:17 UTC, valera
no flags Details

Description valera 2018-11-29 15:00:24 UTC
Created attachment 1509815 [details]
4.18_journalctl _SYSTEMD_UNIT=NetworkManager.service > NetworkManager.txt

Description of problem: doesnt work network after install kernel 4.19.*
4.18 work normaly

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 valera 2018-11-29 15:01:41 UTC
Created attachment 1509817 [details]
4.19_journalctl _SYSTEMD_UNIT=NetworkManager.service > NetworkManager.txt

Comment 2 valera 2018-11-29 15:04:37 UTC
r8168 ethernet card, use r8169 module

Comment 3 Steve 2018-11-29 16:18:42 UTC
This sounds like:

Bug 1653006 - Internet and network don't work after updating kernel from 4.18 to 4.19.2 

Did you try deleting the connection and adding it again?

Comment 4 valera 2018-11-30 20:11:45 UTC
(In reply to Steve from comment #3)
> This sounds like:
> 
> Bug 1653006 - Internet and network don't work after updating kernel from
> 4.18 to 4.19.2 
> 
> Did you try deleting the connection and adding it again?

I try do it, after reboot it doesnt work again, unpluggin cabel...

from 4.19

bash-4.4$ nmcli
virbr0: подключено to virbr0
        "virbr0"
        bridge, 52:54:00:88:6C:D0, sw, mtu 1500
        inet4 192.168.122.1/24
        route4 192.168.122.0/24

enp2s0: недоступен
        "Realtek RTL8111/8168/8411"
        ethernet (r8169), 00:24:8C:6D:38:B7, hw, mtu 1500

lo: без управления
        "lo"
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

virbr0-nic: без управления
        "virbr0-nic"
        tun, 52:54:00:88:6C:D0, sw, mtu 1500

Use "nmcli device show" to get complete information about known devices and
"nmcli connection show" to get an overview on active connection profiles.

Consult nmcli(1) and nmcli-examples(5) manual pages for complete usage details.
bash-4.4$ 

from 4.18.18

bash-4.4$ nmcli
enp2s0: подключено to Профиль 1
        "Realtek RTL8111/8168/8411"
        ethernet (r8169), 00:24:8C:6D:38:B7, hw, mtu 1500
        ip4 default
        inet4 192.168.1.100/24
        route4 0.0.0.0/0
        route4 192.168.1.0/24
        inet6 fe80::4fbb:14d9:12bf:36b1/64
        route6 fe80::/64
        route6 ff00::/8

virbr0: подключено to virbr0
        "virbr0"
        bridge, 52:54:00:88:6C:D0, sw, mtu 1500
        inet4 192.168.122.1/24
        route4 192.168.122.0/24

lo: без управления
        "lo"
        loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

virbr0-nic: без управления
        "virbr0-nic"
bash-4.4$ ^C

Comment 5 Jeremy Cline 2018-11-30 21:04:57 UTC
There's a known issue with a subset of RTL8111 cards and there will be a fix in v4.19.6. Please test it once it's available in updates-testing (probably not before Monday). If it doesn't fix your issue, please re-open this bug.

*** This bug has been marked as a duplicate of bug 1650984 ***

Comment 6 valera 2018-12-04 09:55:13 UTC
kernel 4.19.6 still doesnt work, 4.18.18 work great

-- Reboot --
дек 04 12:42:08 localhost.localdomain NetworkManager[732]: <info>  [1543916528.6493] NetworkManager (version 1.12.4-2.fc29) is starting... (for the first time)
дек 04 12:42:08 localhost.localdomain NetworkManager[732]: <info>  [1543916528.6498] Read config: /etc/NetworkManager/NetworkManager.conf (lib: 20-connectivity-fedora.conf)
дек 04 12:42:08 localhost.localdomain NetworkManager[732]: <info>  [1543916528.7452] bus-manager: acquired D-Bus service "org.freedesktop.NetworkManager"
дек 04 12:42:08 localhost.localdomain NetworkManager[732]: <info>  [1543916528.7610] manager[0x563935d360c0]: monitoring kernel firmware directory '/lib/firmware'.
дек 04 12:42:09 localhost.localdomain NetworkManager[732]: <info>  [1543916529.8179] hostname: hostname: using hostnamed
дек 04 12:42:09 localhost.localdomain NetworkManager[732]: <info>  [1543916529.8184] hostname: hostname changed from (none) to "localhost.localdomain"
дек 04 12:42:09 localhost.localdomain NetworkManager[732]: <info>  [1543916529.8190] dns-mgr[0x563935d40930]: init: dns=default, rc-manager=symlink
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.0772] settings: Loaded settings plugin: SettingsPluginIfcfg (/usr/lib64/NetworkManager/1.12.4-2.fc29/libnm-settings-plugin-ifcfg-rh.so)
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.0815] settings: Loaded settings plugin: NMSIbftPlugin (/usr/lib64/NetworkManager/1.12.4-2.fc29/libnm-settings-plugin-ibft.so)
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.0816] settings: Loaded settings plugin: NMSKeyfilePlugin (internal)
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.0832] ifcfg-rh: new connection /etc/sysconfig/network-scripts/ifcfg-Профиль_1 (4c64fd87-cb5a-4ba7-b8e3-271e7b992c2e,"Профиль 1")
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.1882] manager: rfkill: WiFi enabled by radio killswitch; enabled by state file
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.1890] manager: rfkill: WWAN enabled by radio killswitch; enabled by state file
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.1892] manager: Networking is enabled by state file
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.1898] dhcp-init: Using DHCP client 'dhclient'
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.3142] Loaded device plugin: NMTeamFactory (/usr/lib64/NetworkManager/1.12.4-2.fc29/libnm-device-plugin-team.so)
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.3457] Loaded device plugin: NMAtmManager (/usr/lib64/NetworkManager/1.12.4-2.fc29/libnm-device-plugin-adsl.so)
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.4855] Loaded device plugin: NMBluezManager (/usr/lib64/NetworkManager/1.12.4-2.fc29/libnm-device-plugin-bluetooth.so)
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.4872] Loaded device plugin: NMWwanFactory (/usr/lib64/NetworkManager/1.12.4-2.fc29/libnm-device-plugin-wwan.so)
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.5033] Loaded device plugin: NMWifiFactory (/usr/lib64/NetworkManager/1.12.4-2.fc29/libnm-device-plugin-wifi.so)
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.5052] device (lo): carrier: link connected
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.5056] manager: (lo): new Generic device (/org/freedesktop/NetworkManager/Devices/1)
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.5083] manager: (enp2s0): new Ethernet device (/org/freedesktop/NetworkManager/Devices/2)
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.5096] device (enp2s0): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
дек 04 12:42:10 localhost.localdomain NetworkManager[732]: <info>  [1543916530.6584] modem-manager: ModemManager available
дек 04 12:42:15 localhost.localdomain NetworkManager[732]: <info>  [1543916535.5932] manager: (virbr0): new Bridge device (/org/freedesktop/NetworkManager/Devices/3)
дек 04 12:42:15 localhost.localdomain NetworkManager[732]: <info>  [1543916535.7926] manager: (virbr0-nic): new Tun device (/org/freedesktop/NetworkManager/Devices/4)
дек 04 12:42:15 localhost.localdomain NetworkManager[732]: <info>  [1543916535.8071] device (virbr0-nic): state change: unmanaged -> unavailable (reason 'connection-assumed', sys-iface-state: 'external')
дек 04 12:42:15 localhost.localdomain NetworkManager[732]: <info>  [1543916535.8140] device (virbr0-nic): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.5910] manager: startup complete
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8311] device (virbr0): state change: unmanaged -> unavailable (reason 'connection-assumed', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8386] ifcfg-rh: add connection in-memory (a9337384-5326-4320-877c-ef0c85330a65,"virbr0")
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8402] device (virbr0): state change: unavailable -> disconnected (reason 'connection-assumed', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8423] device (virbr0): Activation: starting connection 'virbr0' (a9337384-5326-4320-877c-ef0c85330a65)
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8427] device (virbr0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8438] device (virbr0): state change: prepare -> config (reason 'none', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8463] keyfile: add connection in-memory (4fc763bb-4ce1-498c-a10c-2b17d43df477,"virbr0-nic")
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8486] device (virbr0-nic): Activation: starting connection 'virbr0-nic' (4fc763bb-4ce1-498c-a10c-2b17d43df477)
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8491] device (virbr0): state change: config -> ip-config (reason 'none', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8502] device (virbr0): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8517] device (virbr0-nic): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8524] device (virbr0-nic): state change: prepare -> config (reason 'none', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8527] device (virbr0): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8530] device (virbr0-nic): state change: config -> ip-config (reason 'none', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8533] device (virbr0): bridge port virbr0-nic was attached
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8533] device (virbr0-nic): Activation: connection 'virbr0-nic' enslaved, continuing activation
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8536] device (virbr0-nic): state change: ip-config -> ip-check (reason 'none', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8544] device (virbr0): state change: secondaries -> activated (reason 'none', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.8548] manager: NetworkManager state is now CONNECTED_LOCAL
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.9035] device (virbr0): Activation: successful, device activated.
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.9076] device (virbr0-nic): state change: ip-check -> secondaries (reason 'none', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.9079] device (virbr0-nic): state change: secondaries -> activated (reason 'none', sys-iface-state: 'external')
дек 04 12:42:16 localhost.localdomain NetworkManager[732]: <info>  [1543916536.9790] device (virbr0-nic): Activation: successful, device activated.
дек 04 12:42:17 localhost.localdomain NetworkManager[732]: <info>  [1543916537.0360] device (virbr0-nic): state change: activated -> unmanaged (reason 'connection-assumed', sys-iface-state: 'external')
дек 04 12:42:17 localhost.localdomain NetworkManager[732]: <info>  [1543916537.0369] device (virbr0): bridge port virbr0-nic was detached
дек 04 12:42:17 localhost.localdomain NetworkManager[732]: <info>  [1543916537.0369] device (virbr0-nic): released from master device virbr0
дек 04 12:43:14 localhost.localdomain NetworkManager[732]: <info>  [1543916594.5214] audit: op="connection-delete" uuid="4c64fd87-cb5a-4ba7-b8e3-271e7b992c2e" name="Профиль 1" pid=1742 uid=1000 result="success"
дек 04 12:43:19 localhost.localdomain NetworkManager[732]: <info>  [1543916599.1246] ifcfg-rh: add connection /etc/sysconfig/network-scripts/ifcfg-Профиль_1 (3d7b34cf-9037-47af-a342-f19a00cad693,"Профиль 1")
дек 04 12:43:19 localhost.localdomain NetworkManager[732]: <info>  [1543916599.1253] audit: op="connection-add" uuid="3d7b34cf-9037-47af-a342-f19a00cad693" name="Профиль 1" pid=1742 uid=1000 result="success"

Comment 7 Jeremy Cline 2018-12-04 15:38:21 UTC
Hi valera,

Please attach the kernel logs from v4.19.6 (journalctl -k -b --no-hostname).

Comment 8 valera 2018-12-04 16:35:04 UTC
Created attachment 1511379 [details]
4.19.6

Comment 9 valera 2018-12-07 20:38:28 UTC
Created attachment 1512664 [details]
4.19.7 from test repo

Comment 10 valera 2018-12-12 09:16:32 UTC
Created attachment 1513625 [details]
journalctl _SYSTEMD_UNIT=NetworkManager.service

Comment 11 valera 2018-12-12 09:17:00 UTC
Created attachment 1513627 [details]
systemctl status NetworkManager

Comment 12 valera 2018-12-12 10:43:39 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1650984#c40 help me!
PS i.e. rmmod r8169; modprobe realtek; modprobe r8169 do it work on 4,19.*, but not auto from boot system

bash-4.4$ uname -a &&systemctl status NetworkManager 
Linux localhost.localdomain 4.19.8-300.fc29.x86_64 #1 SMP Mon Dec 10 15:23:11 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; ven>
   Active: active (running) since Wed 2018-12-12 13:39:59 MSK; 1min 44s ago
     Docs: man:NetworkManager(8)
 Main PID: 721 (NetworkManager)
    Tasks: 4 (limit: 4697)
   Memory: 16.8M
   CGroup: /system.slice/NetworkManager.service
           ├─ 721 /usr/sbin/NetworkManager --no-daemon
           └─1816 /sbin/dhclient -d -q -sf /usr/libexec/nm-dhcp-helper -pf /var>

дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.>
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.>
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.>
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.>
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.>
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.>
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.>
дек 12 13:41:19 localhost.localdomain dhclient[1816]: bound to 192.168.1.100 -->
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.>
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.>
lines 1-21/21 (END)...skipping...
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: enabled)
   Active: active (running) since Wed 2018-12-12 13:39:59 MSK; 1min 44s ago
     Docs: man:NetworkManager(8)
 Main PID: 721 (NetworkManager)
    Tasks: 4 (limit: 4697)
   Memory: 16.8M
   CGroup: /system.slice/NetworkManager.service
           ├─ 721 /usr/sbin/NetworkManager --no-daemon
           └─1816 /sbin/dhclient -d -q -sf /usr/libexec/nm-dhcp-helper -pf /var/run/dhclient-enp2s0.pid -lf /var/lib/NetworkManager/dhclient-35384d4b>

дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.0059] dhcp4 (enp2s0): state changed unknown -> bound
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.0100] device (enp2s0): state change: ip-config -> ip-check (reason 'no>
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.0111] device (enp2s0): state change: ip-check -> secondaries (reason '>
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.0114] device (enp2s0): state change: secondaries -> activated (reason >
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.0119] manager: NetworkManager state is now CONNECTED_LOCAL
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.0975] manager: NetworkManager state is now CONNECTED_SITE
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.0977] policy: set 'Профиль 1' (enp2s0) as default for IPv4 routing and>
дек 12 13:41:19 localhost.localdomain dhclient[1816]: bound to 192.168.1.100 -- renewal in 3070 seconds.
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.1607] device (enp2s0): Activation: successful, device activated.
дек 12 13:41:19 localhost.localdomain NetworkManager[721]: <info>  [1544611279.9404] manager: NetworkManager state is now CONNECTED_GLOBAL

Comment 13 Jeremy Cline 2018-12-12 14:28:47 UTC
Okay, I'm going to remark this as a duplicate as 1650984 since it seems that fix didn't fix things for everyone and the upstream maintainer is working on it on that bug.

*** This bug has been marked as a duplicate of bug 1650984 ***


Note You need to log in before you can comment on or make changes to this bug.