Bug 1654798 - [OSP] Kuryr-Kubernetes needs leader-elector container to be provided by OCP
Summary: [OSP] Kuryr-Kubernetes needs leader-elector container to be provided by OCP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Michał Dulko
QA Contact: Itzik Brown
URL:
Whiteboard:
Depends On:
Blocks: 1579371
TreeView+ depends on / blocked
 
Reported: 2018-11-29 17:20 UTC by Michał Dulko
Modified: 2019-10-16 06:27 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:27:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:27:56 UTC

Description Michał Dulko 2018-11-29 17:20:45 UTC
Description of problem:
leader-elector container required by openshift-ansible installed kuryr-kubernetes is missing from the OpenShift container catalog.

Version-Release number of selected component (if applicable):
3.10

How reproducible:
Always

Steps to Reproduce:
1. Check that there's no container.

Actual results:
Missing.

Expected results:
It's there.

Additional info:

Comment 2 Michał Dulko 2019-01-04 09:47:00 UTC
Okay, the image is there now.

Comment 8 Meng Bo 2019-05-08 10:34:13 UTC
Assign this bug to the reporter, as we are not taking the kuryr bugs.

Comment 9 GenadiC 2019-05-15 07:16:25 UTC
4.1 does not have this as it's blacklisted at the moment.
It should be tested in 4.2 when we'll have kuryr enabled

Comment 11 Weibin Liang 2019-06-13 15:51:47 UTC
mdulko, according to comment 9, could you help to verify this bug? Thanks.

Comment 12 Weibin Liang 2019-08-12 17:51:28 UTC
mdulko@redhat.com

mdulko, according to comment 9, could you help to verify this bug? Thanks.

Comment 13 Michał Dulko 2019-08-29 07:56:13 UTC
I'm going to put this on verified. I was supposed to do that after I verify that the 4.2 leader-elector containers work fine with Kuryr in HA, but it's possible 4.2 will ship without HA enabled. Anyway the container is there and that was the culprit.

Comment 15 errata-xmlrpc 2019-10-16 06:27:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.