Bug 1654838 - pure-ftpd 1.0.47 doesn't support TLSv1.3
Summary: pure-ftpd 1.0.47 doesn't support TLSv1.3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pure-ftpd
Version: 29
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ondřej Lysoněk
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-29 19:39 UTC by mfs-it2
Modified: 2019-04-16 04:03 UTC (History)
7 users (show)

Fixed In Version: pure-ftpd-1.0.48-1.fc30 pure-ftpd-1.0.47-7.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-04-03 00:39:42 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github jedisct1 pure-ftpd issues 94 None None None 2018-11-29 19:40:28 UTC

Description mfs-it2 2018-11-29 19:39:08 UTC
Description of problem:
The 1.0.47 release of pure-ftpd isn't really compatible with OpenSSL 1.1.1 Fedora 29 uses per default. The issue has been patched already by the upstream.

Version-Release number of selected component (if applicable):
pure-ftpd-1.0.47-4

How reproducible:
Attempt to connect using TLS 1.3

Steps to Reproduce:
1. Configure pure-ftpd in order to use TLS
2. Attempt to connect with your client of choice
3. It's impossible to connect

Actual results:
Failure and impossibility to connect

Expected results:
A successful TLS connection

Additional info:
Upstream has fixed the issue already, they simply haven't made a new release yet.

https://github.com/jedisct1/pure-ftpd/issues/94
https://github.com/jedisct1/pure-ftpd/commit/4a495c61ce22c893aed5ee57f6ce0b43c3be59ad

Comment 1 Claudiu 2019-01-23 22:05:03 UTC
Some news on this? Clients like Filezilla has only TLSv1.3 support now. This will break a lot of ftp users if the issue is not patched.

Comment 2 Fedora Update System 2019-02-05 15:41:08 UTC
pure-ftpd-1.0.47-5.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-6e62088c7a

Comment 3 Fedora Update System 2019-02-06 04:35:19 UTC
pure-ftpd-1.0.47-5.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-6e62088c7a

Comment 4 Fedora Update System 2019-02-07 08:47:38 UTC
pure-ftpd-1.0.47-5.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2019-2867b43343

Comment 5 Claudiu 2019-02-09 16:05:33 UTC
Sadly, this patch introduces other bug. Now, TLSv1.3 clients get "uploaded (0 bytes, 0.00KB/sec)" when try to upload their files. 

See the new bug 
https://bugzilla.redhat.com/show_bug.cgi?id=1672494

And from upstream
https://github.com/jedisct1/pure-ftpd/issues/102
This is a big problem, not yet patched, making the ftp server almost useless for most clients.

The temporary workaround will be to disable TLSv1.3 completely until a patch is created.

Comment 6 Fedora Update System 2019-02-10 01:50:39 UTC
pure-ftpd-1.0.47-5.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-2867b43343

Comment 7 Ondřej Lysoněk 2019-02-11 09:27:58 UTC
Are you sure it introduces the bug? I thought it at least partially fixes it, or fixes a much bigger problem.

Comment 8 Claudiu 2019-02-11 09:47:11 UTC
Yes, absolutely sure. On my Fedora 29 box I have installed pure-ftpd-1.0.47-5.fc29, then the latest version from github. Same result.
Now the patch allows you to connect using TLSv1.3, but you face a new issue, maybe bigger, because user have no idea about what is going on. Almost all uploaded files end up 0KB in size. 
This is only happening if you run pure-ftpd with TLSv1.3 enabled, once disabled things are back to the normal.

Comment 9 Ondřej Lysoněk 2019-02-12 11:34:50 UTC
OK, I'll temporarily disable TLSv1.3 support until it's fixed.

Comment 10 Ondřej Lysoněk 2019-02-12 11:45:41 UTC
I unpushed the last update.

Comment 12 Fedora Update System 2019-03-29 17:01:34 UTC
pure-ftpd-1.0.48-1.fc30 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-5ce9452556

Comment 13 Fedora Update System 2019-03-29 20:32:46 UTC
pure-ftpd-1.0.48-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-5ce9452556

Comment 14 Fedora Update System 2019-03-30 17:30:24 UTC
pure-ftpd-1.0.47-7.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2019-3b5a0f8940

Comment 15 Ondřej Lysoněk 2019-03-30 17:35:37 UTC
Regarding Fedora 29, I've decided not to upgrade to pure-ftpd 1.0.48 there, as the new version doesn't appear to be fully backward compatible. Instead I've attempted to backport the fix, however I'm not sure I got it right. So please test.

Comment 16 Fedora Update System 2019-03-31 18:48:52 UTC
pure-ftpd-1.0.47-7.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-3b5a0f8940

Comment 17 Fedora Update System 2019-04-03 00:39:42 UTC
pure-ftpd-1.0.48-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2019-04-16 04:03:40 UTC
pure-ftpd-1.0.47-7.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.