Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1654853 - Upgrading undercloud errors with octavia-amphora-image < 13.0-20180711.1
Summary: Upgrading undercloud errors with octavia-amphora-image < 13.0-20180711.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director-images
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z4
: 13.0 (Queens)
Assignee: Jason Joyce
QA Contact: Gurenko Alex
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-29 20:15 UTC by rlopez
Modified: 2019-01-16 17:01 UTC (History)
9 users (show)

Fixed In Version: rhosp-director-images-13.0-20181220.1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-16 17:01:22 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0071 0 None None None 2019-01-16 17:01:31 UTC

Description rlopez 2018-11-29 20:15:49 UTC
Description of problem:

When attempting an "openstack undercloud upgrade"

the following error arises:

Running transaction check
2018-11-29 20:28:30,661 INFO: ERROR with transaction check vs depsolve:
2018-11-29 20:28:30,662 INFO: octavia-amphora-image < 13.0-20180711.1 is obsoleted by octavia-amphora-image-x86_64-13.0-20181107.1.el7ost.noarch
2018-11-29 20:28:30,662 INFO:  You could try running: rpm -Va --nofiles --nodigest
2018-11-29 20:28:30,662 INFO: Your transaction was saved, rerun it with:
2018-11-29 20:28:30,662 INFO:  yum load-transaction /tmp/yum_save_tx.2018-11-29.20-26.Zjapz3.yumtx
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 2448, in pre_upgrade
    _run_live_command(args, name='yum update')
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 668, in _run_live_command
    raise RuntimeError('%s failed. See log for details.' % name)
RuntimeError: yum update failed. See log for details.
Command 'instack-pre-upgrade-undercloud' returned non-zero exit status 1

Workaround:

yum remove octavia-amphora-image
yum install octavia-amphora-iamge-x86_64

reattempt the upgrade (requires all openstack services to be back online)

Version-Release number of selected component (if applicable):

Comment 1 rlopez 2018-11-29 20:16:19 UTC
misspelled image: yum install octavia-amphora-image-x86_64

Comment 2 Carlos Camacho 2018-12-03 11:35:46 UTC
Hello,

Would you mind to be more explicit about:

* Are you trying to run a minor update or a major upgrade for the Undercloud.?
* Which documentation are you following.?
* What repositories do you have installed.?
* Are you using rhos-release or satellite.?

Looks like a deps issue but without more information, we can not reproduce this.

Comment 3 rlopez 2018-12-04 20:25:51 UTC
Hey Carlos

* Running a minor update of OSP13
* Documentation using: https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/13/html/keeping_red_hat_openstack_platform_updated/
* Repositories installed using CDN:
** rhel-7-server-extras-rpms
** rhel-7-server-openstack-13-rpms
** rrhel-ha-for-rhel-7-server-rpms
** rhel-7-server-rpms
* I'm not using rhos-release or satellite. Using downstream what customers can use from subscription-manager.

Comment 22 errata-xmlrpc 2019-01-16 17:01:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0071


Note You need to log in before you can comment on or make changes to this bug.