Bug 1654858 - r8169 doesn't work with RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06) any more
Summary: r8169 doesn't work with RTL8111/8168/8411 PCI Express Gigabit Ethernet Contro...
Keywords:
Status: CLOSED DUPLICATE of bug 1650984
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-29 20:31 UTC by old_man999
Modified: 2018-12-24 20:47 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-24 20:47:03 UTC
Type: Bug


Attachments (Terms of Use)

Description old_man999 2018-11-29 20:31:12 UTC
Description of problem:

Since kernel version 4.19.2-200.fc28.x86_64 Gigabit Ethernet controller is not working at all. There is no indication of power or link activity at all while the kernel module is loaded after boot. Trying to reload the kernel module results to the following:

[ 1602.320559] libphy: r8169: probed
[ 1602.321173] r8169 0000:26:00.0 eth0: RTL8168e/8111e, e4:11:5b:37:03:33, XID 2c200000, IRQ 37
[ 1602.321176] r8169 0000:26:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[ 1602.329927] r8169 0000:26:00.0 enp38s0: renamed from eth0
[ 1602.347983] IPv6: ADDRCONF(NETDEV_UP): enp38s0: link is not ready
[ 1602.348691] RTL8211DN Gigabit Ethernet r8169-2600:00: attached PHY driver [RTL8211DN Gigabit Ethernet] (mii_bus:phy_addr=r8169-2600:00, irq=IGNORE)
[ 1602.552066] IPv6: ADDRCONF(NETDEV_UP): enp38s0: link is not ready
[ 1604.457944] r8169 0000:26:00.0 enp38s0: Link is Up - 1Gbps/Full - flow control rx/tx
[ 1604.457960] IPv6: ADDRCONF(NETDEV_CHANGE): enp38s0: link becomes ready
[ 1604.467561] r8169 0000:26:00.0 enp38s0: Link is Down
[ 1604.467889] r8169 0000:26:00.0 enp38s0: Link is Up - 1Gbps/Half - flow control off
[ 1605.380810] r8169 0000:26:00.0 enp38s0: Link is Down

During the process there is indication of data being transmitted. After this the hardware link seems to disappear.
With kernel version 4.18.18-200.fc28.x86_64 there are no problems.


How reproducible:

Boot with a 4.19.2 kernel using RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06) hardware

There was an issue recently resolved with this kernel module in same hardware environment also: https://bugzilla.redhat.com/show_bug.cgi?id=1622300

Comment 1 old_man999 2018-11-29 20:48:05 UTC
New kernel module does not depend on and load mii kernel module.

Comment 2 pc 2018-12-01 15:42:48 UTC
After upgrading to Kernel version 4.19.5-200.fc28.x86_64, my card is working again. I have a Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 01).

Comment 3 Jeremy Cline 2018-12-03 21:20:19 UTC
Please give https://bodhi.fedoraproject.org/updates/FEDORA-2018-ce033b4abb a test and let me know if it works, it contains a fix for https://bugzilla.redhat.com/show_bug.cgi?id=1650984 and this is likely the same bug.

Comment 4 Hans de Goede 2018-12-24 20:47:03 UTC
There has been a lot of discussion about issues with RTL ethernet controllers in bug 1650984, as such this is likely the same issue, so I'm marking this as a duplicate.

Bug 1650984 comment 62 has a patch which is believed to fix this (it has been confirmed to fix this by several testers). Jeremy can you perhaps add that patch to the Fedora kernels?

*** This bug has been marked as a duplicate of bug 1650984 ***


Note You need to log in before you can comment on or make changes to this bug.