Bug 1654880 - pykickstart.errors.KickstartError: /usr/sbin/authconfig is missing. Cannot setup authentication.
Summary: pykickstart.errors.KickstartError: /usr/sbin/authconfig is missing. Cannot se...
Keywords:
Status: CLOSED DUPLICATE of bug 1625965
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: anaconda
Version: 8.0
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard: abrt_hash:a78ff5f8e73267de3a932c980b5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-29 22:57 UTC by Jan Gerrit Kootstra
Modified: 2018-12-03 10:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-03 10:02:09 UTC
Type: ---
Target Upstream Version:


Attachments (Terms of Use)
File: anaconda-tb (2.27 MB, text/plain)
2018-11-29 22:57 UTC, Jan Gerrit Kootstra
no flags Details
File: anaconda.log (38.50 KB, text/plain)
2018-11-29 22:57 UTC, Jan Gerrit Kootstra
no flags Details
File: dbus.log (3.65 KB, text/plain)
2018-11-29 22:57 UTC, Jan Gerrit Kootstra
no flags Details
File: dnf.librepo.log (496.45 KB, text/plain)
2018-11-29 22:57 UTC, Jan Gerrit Kootstra
no flags Details
File: environ (637 bytes, text/plain)
2018-11-29 22:57 UTC, Jan Gerrit Kootstra
no flags Details
File: hawkey.log (1.13 KB, text/plain)
2018-11-29 22:57 UTC, Jan Gerrit Kootstra
no flags Details
File: ks.cfg (5.18 KB, text/plain)
2018-11-29 22:57 UTC, Jan Gerrit Kootstra
no flags Details
File: lorax-packages.log (24.11 KB, text/plain)
2018-11-29 22:57 UTC, Jan Gerrit Kootstra
no flags Details
File: lsblk_output (1.64 KB, text/plain)
2018-11-29 22:57 UTC, Jan Gerrit Kootstra
no flags Details
File: lvm.log (919.10 KB, text/plain)
2018-11-29 22:58 UTC, Jan Gerrit Kootstra
no flags Details
File: nmcli_dev_list (1.91 KB, text/plain)
2018-11-29 22:58 UTC, Jan Gerrit Kootstra
no flags Details
File: os_info (513 bytes, text/plain)
2018-11-29 22:58 UTC, Jan Gerrit Kootstra
no flags Details
File: program.log (66.32 KB, text/plain)
2018-11-29 22:58 UTC, Jan Gerrit Kootstra
no flags Details
File: storage.log (159.19 KB, text/plain)
2018-11-29 22:58 UTC, Jan Gerrit Kootstra
no flags Details
File: syslog (189.08 KB, text/plain)
2018-11-29 22:58 UTC, Jan Gerrit Kootstra
no flags Details
File: ifcfg.log (4.21 KB, text/plain)
2018-11-29 22:58 UTC, Jan Gerrit Kootstra
no flags Details
File: packaging.log (233.98 KB, text/plain)
2018-11-29 22:58 UTC, Jan Gerrit Kootstra
no flags Details

Description Jan Gerrit Kootstra 2018-11-29 22:57:38 UTC
Description of problem:


Version-Release number of selected component:
anaconda-29.19.0.25

The following was filed automatically by anaconda:
anaconda 29.19.0.25 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.6/site-packages/pyanaconda/kickstart.py", line 380, in _run
    raise KickstartError(msg)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/kickstart.py", line 373, in execute
    ["--update", "--nostart"] + security_proxy.Authconfig
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 438, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 472, in start
    self.run_task()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation.py", line 205, in doConfiguration
    configuration_queue.start()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threading.py", line 286, in run
    threading.Thread.run(self)
pykickstart.errors.KickstartError: /usr/sbin/authconfig is missing. Cannot setup authentication.

Additional info:
addons:         com_redhat_kdump, org_fedora_oscap
cmdline:        /usr/libexec/platform-python  /sbin/anaconda
cmdline_file:   initrd=boot/RedHat-8.0-x86_64-initrd.img ks=http://satellite.internal.kootstra.co.uk/unattended/provision?token=cb4f34f9-e3d1-46b0-96d3-94417d0e93e2 network ksdevice=bootif ks.device=bootif BOOTIF=00-52-54-00-e2-fe-6b kssendmac ks.sendmac inst.ks.sendmac BOOT_IMAGE=boot/RedHat-8.0-x86_64-vmlinuz BOOTIF=01-52-54-00-e2-fe-6b default PXELinux
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.18.0-32.el8.x86_64
product:        Red Hat Enterprise Linux 8
release:        Red Hat Enterprise Linux release 8.0 Beta (Ootpa)
release_type:   pre-release
type:           anaconda
version:        8.0

Comment 1 Jan Gerrit Kootstra 2018-11-29 22:57:45 UTC
Created attachment 1510001 [details]
File: anaconda-tb

Comment 2 Jan Gerrit Kootstra 2018-11-29 22:57:47 UTC
Created attachment 1510002 [details]
File: anaconda.log

Comment 3 Jan Gerrit Kootstra 2018-11-29 22:57:48 UTC
Created attachment 1510003 [details]
File: dbus.log

Comment 4 Jan Gerrit Kootstra 2018-11-29 22:57:50 UTC
Created attachment 1510004 [details]
File: dnf.librepo.log

Comment 5 Jan Gerrit Kootstra 2018-11-29 22:57:52 UTC
Created attachment 1510005 [details]
File: environ

Comment 6 Jan Gerrit Kootstra 2018-11-29 22:57:53 UTC
Created attachment 1510006 [details]
File: hawkey.log

Comment 7 Jan Gerrit Kootstra 2018-11-29 22:57:54 UTC
Created attachment 1510007 [details]
File: ks.cfg

Comment 8 Jan Gerrit Kootstra 2018-11-29 22:57:56 UTC
Created attachment 1510008 [details]
File: lorax-packages.log

Comment 9 Jan Gerrit Kootstra 2018-11-29 22:57:57 UTC
Created attachment 1510009 [details]
File: lsblk_output

Comment 10 Jan Gerrit Kootstra 2018-11-29 22:58:00 UTC
Created attachment 1510010 [details]
File: lvm.log

Comment 11 Jan Gerrit Kootstra 2018-11-29 22:58:01 UTC
Created attachment 1510011 [details]
File: nmcli_dev_list

Comment 12 Jan Gerrit Kootstra 2018-11-29 22:58:02 UTC
Created attachment 1510012 [details]
File: os_info

Comment 13 Jan Gerrit Kootstra 2018-11-29 22:58:04 UTC
Created attachment 1510013 [details]
File: program.log

Comment 14 Jan Gerrit Kootstra 2018-11-29 22:58:06 UTC
Created attachment 1510014 [details]
File: storage.log

Comment 15 Jan Gerrit Kootstra 2018-11-29 22:58:08 UTC
Created attachment 1510015 [details]
File: syslog

Comment 16 Jan Gerrit Kootstra 2018-11-29 22:58:09 UTC
Created attachment 1510016 [details]
File: ifcfg.log

Comment 17 Jan Gerrit Kootstra 2018-11-29 22:58:11 UTC
Created attachment 1510017 [details]
File: packaging.log

Comment 18 Jiri Konecny 2018-11-30 08:56:01 UTC
Hello, 

From my understanding you are installing without AppStream repository. If that is correct then this is an expected issue. The auth & authconfig KS commands could be used only with the AppStream repository used during the installation and you should use authselect instead of that.

Could you please confirm my assumption?

Comment 19 Jan Gerrit Kootstra 2018-11-30 19:09:39 UTC
Hello Jiri,

I use the kickstart that is provided by Red Hat as a Satellite 6.4 content, I did not change anything of its content.

I have no clue of its content.

Regards,

Jan Gerrit

Comment 20 Jan Gerrit Kootstra 2018-11-30 19:26:31 UTC
Rerunning anaconda I found Appstream content was not available on the Satellite server. Will sync the content and try a new installation.

Comment 21 Jan Gerrit Kootstra 2018-11-30 20:19:06 UTC
adding the Appstream repository does not seem to fix the issue. 

At the start of the installation I get a warning ntp, redhat-lsb-core, wget and authselect-compat are missing from the installation source

Comment 22 Jiri Konecny 2018-12-03 10:02:09 UTC
I asked Sattelite and they already have a bug on this issue. So closing as a duplicate.

Thanks a lot Jan for your investigation work.

*** This bug has been marked as a duplicate of bug 1625965 ***


Note You need to log in before you can comment on or make changes to this bug.