Bug 1654899 - RFE: comments, history
Summary: RFE: comments, history
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: All
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: nsella
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-30 00:18 UTC by Michal Schorm
Modified: 2020-06-19 01:05 UTC (History)
5 users (show)

Fixed In Version: dnf-4.2.23-1.fc32 dnf-4.2.23-1.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-05 02:29:48 UTC
Type: Bug


Attachments (Terms of Use)

Description Michal Schorm 2018-11-30 00:18:43 UTC
Hello, I have a RFE for DNF history and comments.

I will paste here a sample DNF output from my real server:

Comment 1 Michal Schorm 2018-11-30 00:19:31 UTC
[root@SERVER ~]# dnf history
ID     | Příkazový řádek          | Datum a čas      | Akce           | Pozměně
-------------------------------------------------------------------------------
    19 | install --comment=Mumble | 2018-11-30 00:05 | Install        |   19   
    18 | install pulseaudio-modul | 2018-11-29 03:44 | Install        |    1   
    17 | install jack-audio-conne | 2018-11-29 03:42 | Install        |    1   
    16 | install alsa-plugins-pul | 2018-11-29 03:33 | Install        |    5   
    15 | install zip              | 2018-11-29 00:55 | Install        |    1   
    14 | install xorg-x11-xinit   | 2018-11-29 00:17 | Install        |    9   
    13 | install xorg-x11-server- | 2018-11-29 00:16 | Install        |   10   
    12 | install libXcursor       | 2018-11-29 00:14 | Install        |    1   
    11 | install nss.x86_64       | 2018-11-29 00:13 | Install        |    1 EE
    10 | install libnss3.so       | 2018-11-29 00:03 | Install        |   13 EE
     9 | install unzip            | 2018-11-28 23:44 | Install        |    1   
     8 | install bzip2            | 2018-11-28 23:32 | Install        |    1   
     7 | install -y --nogpgcheck  | 2018-11-28 21:54 | Install        |  194   
     6 | install -y --nogpgcheck  | 2018-11-28 21:53 | Install        |    1   
     5 | --comment=IRC client ins | 2018-11-28 21:48 | Install        |    9   
     4 | --comment=IRC server ins | 2018-11-28 21:47 | Install        |    2   
     3 | --comment=nmcli, wifi in | 2018-11-28 21:46 | Install        |    3   
     2 | --comment=Basic software | 2018-11-28 21:44 | Install        |   97   
     1 |                          | 2018-11-28 21:31 | Install        |  311 EE
[root@SERVER ~]# dnf history info 19
ID transakce: 19
Počáteční čas  : Pá 30. listopadu 2018, 00:05:54 CET
Začátek rpmdb  : 659:6622f66c164fcf850ead6c1f8147d54131f6d36e
Čas ukončení    : Pá 30. listopadu 2018, 00:06:08 CET (14 sekund)
Konec rpmdb    : 678:bff9e85769ae75cc41ba4dce25a75e8c96350d6c
Uživatel       : root <root>
Návratový kód  : Úspěšné
Releasever     : 29
Příkazový řádek: install --comment=Mumble server and client -y --nogpgcheck murmur mumble
Pozměněné balíčky:
    Instalovat jbigkit-libs-2.1-15.fc29.x86_64                 @updates
    Instalovat libtiff-4.0.10-1.fc29.x86_64                    @updates
    Instalovat qt-1:4.8.7-44.fc29.x86_64                       @updates
    Instalovat qt-common-1:4.8.7-44.fc29.noarch                @updates
    Instalovat qt-x11-1:4.8.7-44.fc29.x86_64                   @updates
    Instalovat avahi-compat-libdns_sd-0.7-16.fc29.x86_64       @fedora
    Instalovat celt071-0.7.1-16.fc29.x86_64                    @fedora
    Instalovat dbusmenu-qt-0.9.3-0.18.20150604.fc29.x86_64     @fedora
    Instalovat dotconf-1.3-19.fc29.x86_64                      @fedora
    Instalovat espeak-ng-1.49.2-4.fc29.x86_64                  @fedora
    Instalovat libao-1.2.0-13.fc29.x86_64                      @fedora
    Instalovat libmng-2.0.3-8.fc29.x86_64                      @fedora
    Instalovat mumble-1.2.19-10.fc29.x86_64                    @fedora
    Instalovat murmur-1.2.19-10.fc29.x86_64                    @fedora
    Instalovat pcaudiolib-1.1-2.fc29.x86_64                    @fedora
    Instalovat protobuf-3.5.0-8.fc29.x86_64                    @fedora
    Instalovat sni-qt-0.2.6-12.fc29.x86_64                     @fedora
    Instalovat speech-dispatcher-0.8.8-8.fc29.x86_64           @fedora
    Instalovat speech-dispatcher-espeak-ng-0.8.8-8.fc29.x86_64 @fedora

Comment 2 Michal Schorm 2018-11-30 00:35:10 UTC
You can see that:

1)
In the "dnf history" command, there is a lot of "install ..." in the second column. Which I wouldn't really like to see, because there is a separate column no. 4. for that information.

2)
Also column no. 4. seems IMHO unnecesarily wide

3)
Asi that you can see also comments in the second column. They were created with command:
# dnf --comment="Some comment" install some-package

However they are stored with the "--comment=" part, but without the quotation marks. Instead of the "--comment=" part, I like to see that actual comment.

4)
What would be most awesome, to see the whole, not clipped, comment.
Even if that would mean to use aditional option. Like f.e.:
# dnf history --wide

5)
The "dnf history info <number>" doesn't show the comment, aside from the actual command line input - which is again without quotation marks used around that comment.

-----

I'd like to use comments to add some aditional information to the transaction to my later myself.
Because - you know - who remember, why he installed that weird package 11 months back?

Comments should make orientation in the DNF history easier.
It should IMHO help the system administrator understand, what he was doing. Help to hunt down his mistakes. Or help him to reproduce something he managed well - but he forgot which packages he needed for that.
It should be explanatory for other sysadmins to understand how the server was set up.

When I remember - "IRC server, what did I needed for that?" - I should easily find a pair - comment and list of packages changed on the system.

Comment 3 Daniel Mach 2020-05-22 04:24:42 UTC
Comment option was added here:
https://github.com/rpm-software-management/dnf/pull/1598

History output width was fixed here:
https://github.com/rpm-software-management/dnf/pull/1559

Comment 4 Fedora Update System 2020-06-03 08:55:06 UTC
FEDORA-2020-f3f7292b39 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2020-f3f7292b39

Comment 5 Fedora Update System 2020-06-04 03:00:18 UTC
FEDORA-2020-f3f7292b39 has been pushed to the Fedora 31 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-f3f7292b39`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-f3f7292b39

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2020-06-04 04:08:26 UTC
FEDORA-2020-a943fde9ba has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-a943fde9ba`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-a943fde9ba

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2020-06-05 02:29:48 UTC
FEDORA-2020-a943fde9ba has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 8 Fedora Update System 2020-06-19 01:05:18 UTC
FEDORA-2020-f3f7292b39 has been pushed to the Fedora 31 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.