Bug 1654907 - Prometheus restricted to eth0
Summary: Prometheus restricted to eth0
Keywords:
Status: CLOSED DUPLICATE of bug 1670330
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Frederic Branczyk
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-30 02:05 UTC by Greg Rodriguez II
Modified: 2019-07-23 15:15 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-06 15:35:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Greg Rodriguez II 2018-11-30 02:05:51 UTC
Description of problem:
Prometheus is not able to pull data using a NIC outside of eth0

Version-Release number of selected component (if applicable):
OCP 3.11

How reproducible:
Customer verified

Steps to Reproduce:
1. Project set to use "ens160" NIC in Prometheus
2. NIC setting automatically rolls back to "eth0"
3. Unable to pull metrics

Actual results:
Unable to collect metric data in Prometheus due to inability to set NIC outside of "eth0"

Expected results:
Ability to change NIC settings as needed

Additional info:
N/A

Comment 2 Junqi Zhao 2018-11-30 05:33:11 UTC
Important

Network utilization metrics for OpenShift Container Platform are only collected for eth0 network interfaces. Therefore, network utilization trend will not be displayed for network interfaces other than eth0 on the overview screen of the provider.

Comment 3 Frederic Branczyk 2018-11-30 07:27:06 UTC
Thank you for reporting this, we should make this configurable. From the description is sounds like the data may be collected though, just not alerted on. Can you validate this by checking whether this query shows records you expected?

node_network_receive_bytes_total{job="node-exporter"}

Comment 9 Frederic Branczyk 2019-02-04 14:33:56 UTC
https://github.com/openshift/cluster-monitoring-operator/pull/226 was merged to only exclude virtual interfaces and not whitelist only eth0.

Comment 13 Junqi Zhao 2019-03-06 15:35:14 UTC

*** This bug has been marked as a duplicate of bug 1670330 ***


Note You need to log in before you can comment on or make changes to this bug.