Bug 1654953 - [admin] Removing subscription does not redirect to subscription menu page
Summary: [admin] Removing subscription does not redirect to subscription menu page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Alec Merdler
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-30 07:19 UTC by XiaochuanWang
Modified: 2019-03-22 12:08 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-22 12:08:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description XiaochuanWang 2018-11-30 07:19:57 UTC
Description of problem:
Make sure user has olm operators, subscript one of a CatalogSource from PackageMenifests such as "etcd". Browse to Subscription -> etcd, click Actions -> Remove Subscriptions. It is still stay on current page instead of jumping to Subscription list.

Version-Release number of selected component (if applicable):
oc v4.0.0-0.74.0
registry.reg-aws.openshift.com:443/openshift/ose-console   v4.0   32d268ebfeeb

How reproducible:
Always

Steps to Reproduce:
1. Make sure user has olm operators, subscript one of a CatalogSource from PackageMenifests such as "etcd". 
2. Browse to Subscription -> etcd, click Actions -> Remove Subscriptions.

Actual results:
2. It is still stay on current page instead of jumping to Subscription list.

Expected results:
2. Since the subscription is actually removed, it should direct to Subscription list page.

Additional info:
The subscription is actually removed.

Comment 1 XiaochuanWang 2018-11-30 07:47:34 UTC
Add additional info:
1. Remove in kebab button works.
2. $ oc get subscription could get the correct result which the subscription has been actually removed.

Comment 2 Samuel Padgett 2019-03-19 19:52:45 UTC
https://github.com/openshift/console/pull/1305

Comment 3 XiaochuanWang 2019-03-22 06:25:26 UTC
Now it behave correctly on latest OCP4. When user delete the subscription from Action, the page will go back to Operator Management page to display subscription list. Also the ClusterServiceVersion deletion will jump back to Installed Operators page which behave correctly.

Verified on 4.0.0-0.nightly-2019-03-21-164511


Note You need to log in before you can comment on or make changes to this bug.