Bug 1654960 - [admin] Useless link 'View catalog details' on operator detail page under project "openshift-operator-lifecycle-manage" and "operator-lifecycle-manager"
Summary: [admin] Useless link 'View catalog details' on operator detail page under pro...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.1.0
Assignee: Alec Merdler
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-30 08:02 UTC by XiaochuanWang
Modified: 2019-06-04 10:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:09 UTC

Description XiaochuanWang 2018-11-30 08:02:08 UTC
Description of problem:
Make user olm is installed. Check the operators pages such as k8s/ns/openshift-operator-lifecycle-manager/operators.coreos.com~v1alpha1~CatalogSource/rh-operators, k8s/ns/operator-lifecycle-manager/operators.coreos.com~v1alpha1~CatalogSource/certified-operators. The link "View catalog details" is useless. 

Version-Release number of selected component (if applicable):
registry.reg-aws.openshift.com:443/openshift/ose-console                   v4.0                32d268ebfeeb        2 days ago          258 MB

How reproducible:
Always

Steps to Reproduce:
1. Make user olm is installed. Select project openshift-operator-lifecycle-manage. Go to Package Manifests -> click "View catalog details"

2. Check the operators pages such as k8s/ns/openshift-operator-lifecycle-manager/operators.coreos.com~v1alpha1~CatalogSource/rh-operators

3. Select project operator-lifecycle-manager, click certified-operators and check the current page such as  k8s/ns/operator-lifecycle-manager/operators.coreos.com~v1alpha1~CatalogSource/certified-operators

Actual results:
Both 2&3, the "View catalog details" displays but it's useless because it links to the current page.

Expected results:
Both 2&3, should not display "View catalog details"

Additional info:

Comment 1 Alec Merdler 2018-12-11 20:08:08 UTC
https://github.com/openshift/console/pull/935

Comment 3 XiaochuanWang 2019-04-04 09:57:47 UTC
Now the pages about this feature are correctly accept. Thanks!
Verified on 4.0.0-0.nightly-2019-04-03-202419

Comment 5 errata-xmlrpc 2019-06-04 10:41:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.