Bug 1654966 - OpenShift version print not correctly with latest 3.2.1.34 rebuild
Summary: OpenShift version print not correctly with latest 3.2.1.34 rebuild
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 3.2.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: ---
Assignee: Tim Bielawa
QA Contact: Wei Sun
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-30 08:23 UTC by Chuan Yu
Modified: 2019-05-07 19:32 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-07 19:32:15 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Chuan Yu 2018-11-30 08:23:22 UTC
Description of problem:
OpenShift version print not correctly with latest 3.2.1.34 rebuild version

Version-Release number of selected component (if applicable):
openshift v3.2.1.34
kubernetes v1.2.0-36-g4a3f9c5
etcd 2.2.5

atomic-openshift-3.2.1.34-2.git.20.6367d5d


How reproducible:


Steps to Reproduce:
1.run `openshift version` on master node
2.
3.

Actual results:
openshift v3.2.1.34-20-g6367d5d
kubernetes v1.2.0-36-g4a3f9c5
etcd 2.2.5


Expected results:
openshift v3.2.1.34
kubernetes v1.2.0-36-g4a3f9c5
etcd 2.2.5


Additional info:
The issue happened with v3.2.1.34 latest rebuild version atomic-openshift-3.2.1.34-2.git.20.6367d5d

Comment 1 Tim Bielawa 2018-12-07 14:10:56 UTC
Hi there, I'm moving this into the Command Line Interface component. The Release component doesn't have insight into changing how the version appears, sounds like that's something on the code side of things. I hope this is the right place to move it!

Comment 2 Juan Vallejo 2018-12-07 15:03:40 UTC
Hi Chuan,

Could you clarify what exactly the issue is?
The only difference I am seeing is that the version printed in the latest rebuild (v3.2.1.34-20-g6367d5d) has an additional "-20-g6367d5d", and as far as I can tell, this should not be an issue. 

Thanks

Comment 3 Chuan Yu 2018-12-10 06:49:38 UTC
No impacted issues found so far.

But the printed version should be consistent with former release.

Comment 4 Juan Vallejo 2018-12-20 22:20:36 UTC
Moving to installer team. Although I do not believe that this is a bug / issue.

Comment 5 Scott Dodson 2018-12-21 13:55:04 UTC
The version inside the binary is minted during the atomic-openshift RPM build process. Moving back to release component.


Note You need to log in before you can comment on or make changes to this bug.