Bug 1655029 - CLI - missing options in `hammer host create -h` on one setup compared to another setup
Summary: CLI - missing options in `hammer host create -h` on one setup compared to ano...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts - Content
Version: 6.5.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Stephen Wadeley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-30 11:32 UTC by Jan Hutař
Modified: 2020-06-08 13:14 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-06-08 13:14:35 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Hutař 2018-11-30 11:32:26 UTC
Description of problem:
There are missing options in `hammer host create -h` on one setup compared to another setup


Version-Release number of selected component (if applicable):
tfm-rubygem-hammer_cli-0.15.1-1.el7sat.noarch
satellite-6.5.0-5.beta.el7sat.noarch


How reproducible:
always


Steps to Reproduce:
1. # rm -rf ~/.hammer
2. # foreman-rake apipie:cache
3. # hammer --reload-cache host create -h | grep content


Actual results:
Faulty Satellite:
# hammer --reload-cache host create -h | grep content
 --content-source CONTENT_SOURCE_NAME      Content Source name

OK Satellite:
# hammer --reload-cache -u admin -p changeme host create --help | grep content
 --content-source CONTENT_SOURCE_NAME                          Content Source name
 --content-source-id CONTENT_SOURCE_ID                          
 --content-view CONTENT_VIEW_NAME                              Name to search by
 --content-view-id CONTENT_VIEW_ID                             Content view numeric identifier


Expected results:
Outputs should match


Additional info:
# hammer --version
hammer (0.15.1)
 * hammer_cli_csv (unknown version)
 * hammer_cli_foreman (0.15.1)
 * hammer_cli_foreman_admin (0.0.8)
 * hammer_cli_foreman_ansible (unknown version)
 * hammer_cli_foreman_bootdisk (0.1.3.3)
 * hammer_cli_foreman_discovery (1.0.0)
 * hammer_cli_foreman_docker (unknown version)
 * hammer_cli_foreman_openscap (0.1.6)
 * hammer_cli_foreman_remote_execution (unknown version)
 * hammer_cli_foreman_tasks (unknown version)
 * hammer_cli_foreman_templates (0.1.2)
 * hammer_cli_foreman_virt_who_configure (unknown version)
 * hammer_cli_katello (0.15.0)
# rpm -qa | grep -e foreman -e katello -e hammer | sort
foreman-1.20.0-1.el7sat.noarch
foreman-bootloaders-redhat-201801241201-3.el7sat.noarch
foreman-bootloaders-redhat-tftpboot-201801241201-3.el7sat.noarch
foreman-cli-1.20.0-1.el7sat.noarch
foreman-compute-1.20.0-1.el7sat.noarch
foreman-debug-1.20.0-1.el7sat.noarch
foreman-discovery-image-3.5.3-1.el7sat.noarch
foreman-ec2-1.20.0-1.el7sat.noarch
foreman-gce-1.20.0-1.el7sat.noarch
foreman-installer-1.20.0-1.el7sat.noarch
foreman-installer-katello-3.9.0-1.el7sat.noarch
foreman-libvirt-1.20.0-1.el7sat.noarch
foreman-openstack-1.20.0-1.el7sat.noarch
foreman-ovirt-1.20.0-1.el7sat.noarch
foreman-postgresql-1.20.0-1.el7sat.noarch
foreman-proxy-1.20.0-1.el7sat.noarch
foreman-rackspace-1.20.0-1.el7sat.noarch
foreman-selinux-1.20.0-1.el7sat.noarch
foreman-vmware-1.20.0-1.el7sat.noarch
katello-3.9.0-1.el7sat.noarch
katello-certs-tools-2.4.0-2.el7sat.noarch
katello-client-bootstrap-1.6.0-1.el7sat.noarch
katello-common-3.9.0-1.el7sat.noarch
katello-debug-3.9.0-1.el7sat.noarch
katello-default-ca-1.0-1.noarch
katello-installer-base-3.9.0-1.el7sat.noarch
katello-selinux-3.0.3-2.el7sat.noarch
katello-server-ca-1.0-1.noarch
katello-service-3.9.0-1.el7sat.noarch
pulp-katello-1.0.2-5.el7sat.noarch
puppet-foreman_scap_client-0.3.19-1.el7sat.noarch
....com-foreman-client-1.0-1.noarch
....com-foreman-proxy-1.0-1.noarch
....com-foreman-proxy-client-1.0-1.noarch
rubygem-foreman_maintain-0.3.0-1.el7sat.noarch
tfm-rubygem-foreman_ansible-2.2.11-1.el7sat.noarch
tfm-rubygem-foreman_ansible_core-2.1.2-2.el7sat.noarch
tfm-rubygem-foreman_bootdisk-14.0.0-1.el7sat.noarch
tfm-rubygem-foreman_discovery-14.0.0-1.el7sat.noarch
tfm-rubygem-foreman_docker-4.1.0-2.el7sat.noarch
tfm-rubygem-foreman_hooks-0.3.15-1.el7sat.noarch
tfm-rubygem-foreman_openscap-0.11.1-1.el7sat.noarch
tfm-rubygem-foreman_remote_execution-1.6.5-1.el7sat.noarch
tfm-rubygem-foreman_remote_execution_core-1.1.4-1.el7sat.noarch
tfm-rubygem-foreman-tasks-0.14.3-1.el7sat.noarch
tfm-rubygem-foreman-tasks-core-0.2.5-2.el7sat.noarch
tfm-rubygem-foreman_templates-6.0.3-2.el7sat.noarch
tfm-rubygem-foreman_theme_satellite-3.0.1.4-1.el7sat.noarch
tfm-rubygem-foreman_virt_who_configure-0.2.2-2.el7sat.noarch
tfm-rubygem-hammer_cli-0.15.1-1.el7sat.noarch
tfm-rubygem-hammer_cli_csv-2.3.1-3.el7sat.noarch
tfm-rubygem-hammer_cli_foreman-0.15.1-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_admin-0.0.8-3.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_ansible-0.1.1-3.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3.3-4.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_discovery-1.0.0-3.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.6-4.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_openscap-0.1.6-2.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_remote_execution-0.1.0-2.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.13-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_templates-0.1.2-1.el7sat.noarch
tfm-rubygem-hammer_cli_foreman_virt_who_configure-0.0.3-3.el7sat.noarch
tfm-rubygem-hammer_cli_katello-0.15.0-1.el7sat.noarch
tfm-rubygem-katello-3.9.0-1.el7sat.noarch

Comment 3 Jan Hutař 2018-12-11 20:41:33 UTC
Sorry, I have caused some confusion here with:

> Steps to Reproduce:
> 1. # rm -rf ~/.hammer
> 2. # foreman-rake apipie:cache
> 3. # hammer --reload-cache host create -h | grep content

This is not a reproducer, these are steps I have tried to fix the situation. I do not know actual reproducer steps.

Comment 5 Bryan Kearney 2020-05-01 14:23:07 UTC
The Satellite Team is attempting to provide an accurate backlog of bugzilla requests which we feel will be resolved in the next few releases. We do not believe this bugzilla will meet that criteria, and have plans to close it out in 1 month. This is not a reflection on the validity of the request, but a reflection of the many priorities for the product. If you have any concerns about this, feel free to contact Red Hat Technical Support or your account team. If we do not hear from you, we will close this bug out. Thank you.

Comment 6 Bryan Kearney 2020-06-08 13:14:35 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and while we recognize that it is a valid request, we do not expect this to be implemented in the product in the foreseeable future. This is due to other priorities for the product, and not a reflection on the request itself. We are therefore closing this out as WONTFIX. If you have any concerns about this, please do not reopen. Instead, feel free to contact Red Hat Technical Support. Thank you.


Note You need to log in before you can comment on or make changes to this bug.