Bug 1655087 - [downstream clone - 4.2.8] Command entities left in ACTIVE state after HostUpgradeCheckCommand
Summary: [downstream clone - 4.2.8] Command entities left in ACTIVE state after HostUp...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.5
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ovirt-4.2.8
: ---
Assignee: Ravi Nori
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On: 1648417
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-30 14:34 UTC by RHV bug bot
Modified: 2019-06-19 06:15 UTC (History)
8 users (show)

Fixed In Version: ovirt-engine-4.2.8.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1648417
Environment:
Last Closed: 2019-01-22 12:44:51 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0121 0 None None None 2019-01-22 12:44:59 UTC
oVirt gerrit 95395 0 master MERGED engine: Command entities left in ACTIVE state after HostUpgradeCheckCommand 2020-05-03 11:52:02 UTC
oVirt gerrit 96001 0 ovirt-engine-4.2 MERGED engine: Command entities left in ACTIVE state after HostUpgradeCheckCommand 2020-05-03 11:52:05 UTC

Description RHV bug bot 2018-11-30 14:34:34 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1648417 +++
======================================================================

Description of problem:

A customer ran the RHV Log Analyzer tool prior to performing an upgrade and found some "pending engine commands".

The command_entities table contained two ACTIVE commands, left over from previous host upgrade checks.


Version-Release number of selected component (if applicable):

RHV 4.2.5


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

(Originally by Gordon Watson)

Comment 5 RHV bug bot 2018-11-30 14:34:51 UTC
Hi Ravi, can you please provide reproduction steps here?

(Originally by Lukas Svaty)

Comment 6 RHV bug bot 2018-11-30 14:34:55 UTC
Reproduction steps

From webadmin start "Check for Upgrade". After the check for upgrade finishes no command entities should be left in the command_entities table related to the check for upgrade command which should be command_type 141 and 142.

(Originally by Ravi Shankar Nori)

Comment 7 RHV bug bot 2018-11-30 14:34:58 UTC
WARN: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.2.z': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.2.z': '?'}', ]

For more info please contact: rhv-devops@redhat.com

(Originally by rhv-bugzilla-bot)

Comment 10 Petr Matyáš 2018-12-14 11:27:26 UTC
Verified on ovirt-engine-4.2.8.1-0.1.el7ev.noarch

Comment 12 errata-xmlrpc 2019-01-22 12:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0121


Note You need to log in before you can comment on or make changes to this bug.