Bug 1655092 - kubevirt apb v3.11-14 does not use registry_url to template CDI components
Summary: kubevirt apb v3.11-14 does not use registry_url to template CDI components
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Container Native Virtualization (CNV)
Classification: Red Hat
Component: Installation
Version: 1.3
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: 1.4
Assignee: Ohad Levy
QA Contact: Irina Gulina
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-30 15:07 UTC by Joseph Callen
Modified: 2018-12-04 13:31 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-04 13:31:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Joseph Callen 2018-11-30 15:07:10 UTC
Description of problem:

When trying to run the kubevirt apb in an offline mode using the registry_url apb parameter is not used when templating the CDI deployments causing the pods fail to start.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

    ---
    apiVersion: servicecatalog.k8s.io/v1beta1
    kind: ServiceInstance
    metadata:
      name: kubevirt
      namespace: kube-system
    spec:
      clusterServiceClassExternalName: localregistry-virtualization
      clusterServicePlanExternalName: default
      parameters:
        admin_user: admin
        admin_password: ...
        registry_url: docker-registry.default.svc:5000
        registry_namespace: openshift
        version: 0.9.3
        docker_tag: v1.3.0


Actual results:


Expected results:


Additional info:

Is this related?
https://bugzilla.redhat.com/show_bug.cgi?id=1644689

Comment 1 Ryan Hallisey 2018-11-30 15:14:08 UTC
What registry do the cdi images pull from?

Comment 2 Joseph Callen 2018-11-30 15:19:27 UTC
(In reply to Ryan Hallisey from comment #1)
> What registry do the cdi images pull from?

The openshift registry.  In the process of performing an offline install for the lab we are providing we pull from brew then push into the openshift registry.  I don't have the cluster that I tested this on but when I looked at the deployments the none of the image parameters had the `registry_url` provided.  The other components had no issues.

Comment 3 Joseph Callen 2018-11-30 15:20:24 UTC
(In reply to Joseph Callen from comment #2)
> (In reply to Ryan Hallisey from comment #1)
> > What registry do the cdi images pull from?
> 
> The openshift registry.  In the process of performing an offline install for
> the lab we are providing we pull from brew then push into the openshift
> registry.  I don't have the cluster that I tested this on but when I looked
> at the deployments the none of the image parameters had the `registry_url`

To be specific the CDI deployments

> provided.  The other components had no issues.

Comment 4 Ryan Hallisey 2018-11-30 15:28:10 UTC
If you do get the environment back up can you paste the image that the cdi deployment attempted to pull from?  If I understand what you saying, all the working components images should have as a registry 'docker-registry.default.svc:5000', but cdi deployments do not.  I'll see if there are any clues in the code as to what this is.

Comment 5 Joseph Callen 2018-11-30 18:00:28 UTC
Rebuilt...I can get you access if you want it.


CDI Deployments
> oc get deploy -l cdi.kubevirt.io --template '{{ range .items }} {{ range .spec.template.spec.containers }} {{ .image }}{{end}}{{end}}'

cnv-tech-preview/virt-cdi-apiserver:v1.3.0  
cnv-tech-preview/virt-cdi-controller:v1.3.0
cnv-tech-preview/virt-cdi-uploadproxy:v1.3.0

^ missing registry_url

kubevirt deployments

> oc get deploy --template '{{ range .items }} {{ range .spec.template.spec.containers }} {{ .image }}{{end}}{{end}}'

docker-registry.default.svc:5000/cnv-tech-preview/virt-api:v1.3.0
docker-registry.default.svc:5000/cnv-tech-preview/virt-controller:v1.3.0

DaemonSets

> oc get ds  --template '{{ range .items }} {{ range.spec.template.spec.containers }} {{ .image }}{{end}}{{end}}'

docker-registry.default.svc:5000/cnv-tech-preview/multus-cni:v1.3.0
docker-registry.default.svc:5000/cnv-tech-preview/ovs-cni-plugin:v1.3.0
docker-registry.default.svc:5000/openshift3/node:latest
^ this is a bug too.  This _should_ be ose-node:v3.11
docker-registry.default.svc:5000/cnv-tech-preview/virt-handler:v1.3.0

Comment 6 Ryan Hallisey 2018-11-30 18:33:30 UTC
Thanks.

-docker_prefix: "{{ cdi_repo_tag | default('cnv-tech-preview') }}" 
+docker_prefix: "{{ registry_url }}/{{ registry_namespace }}"

Comment 7 Ryan Hallisey 2018-11-30 18:36:33 UTC
cnv-tech-preview is the correct downstream repo so this bug isn't breaking. Will need acks from PM and QE to build.

Comment 8 Nelly Credi 2018-12-04 13:31:56 UTC
we have decided to close it for now, 
because the issue comes from kubevirt-ansible, and we probably wont hit it with the operators


Note You need to log in before you can comment on or make changes to this bug.