Bug 16551 - "mouse --kickstart none" in ks.cfg doesn't work
Summary: "mouse --kickstart none" in ks.cfg doesn't work
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brock Organ
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-18 21:48 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-21 16:03:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-08-18 21:48:15 UTC
Using kickstart with "mouse --kickstart none" in ks.cfg my produces a
python syntax error.

The following patch fixes the problem.

kickstart.py
228,229c228
<       (args, extra) = isys.getopt(args, '', [ 'device=', 'emulthree',
<                                     'kickstart'])
---
>       (args, extra) = isys.getopt(args, '', [ 'device=', 'emulthree' ])


-- Alf.

-----------------------------------------------------------------------
  Alf Wachsmann                       | e-mail: alfw@slac.stanford.edu
  SLAC Computing Service              | Phone:  +1-650-926-4802
  2575 Sand Hill Road, M/S 97         | FAX:    +1-650-926-3329
  Menlo Park, CA 94025, USA           | Office: Bldg. 50/323
-----------------------------------------------------------------------
                http://www.slac.stanford.edu/~alfw (PGP)
-----------------------------------------------------------------------

Comment 1 Michael Fulbright 2000-08-21 16:03:20 UTC
Brock - please verify this is fixed in pinstripe, the above patch already
appears to have been applied.

Comment 2 Brent Fox 2000-08-21 19:48:35 UTC
I tried to reproduce this bug and Anaconda crashes.  I get a Python traceback
that says:
Type Error: bad argument --kickstart: unknown option

According to the kickstart documentation for 6.2
(http://www.redhat.com/support/manuals/RHL-6.2-Manual/ref-guide/s1-kickstart2-commands.html),
--kickstart is not a valid entry for the mouse in the kickstart file.  However,
I've seen other reports in Bugzilla from other people trying to use the
--kickstart option.  Where does this come from?

Closing as not a bug.

Comment 3 Steven Roberts 2001-02-05 09:22:46 UTC
Hey RedHat folks.  while trying to find help on my 'part' bug, found one example of the bad --kickstart arg to mouse reference:
http://www.linuxworld.com/linuxworld/lw-1999-12/lw-12-kickstart.html

both the HOWTO, and the RH Ref Guide make no mention BTW.


Note You need to log in before you can comment on or make changes to this bug.