Bug 1655101 - Missing provides in perl-lasso
Summary: Missing provides in perl-lasso
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: lasso
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Hrozek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-30 15:46 UTC by Xavier Bachelot
Modified: 2019-02-01 01:58 UTC (History)
3 users (show)

Fixed In Version: lasso-2.6.0-10.fc30 lasso-2.6.0-10.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-18 13:25:55 UTC


Attachments (Terms of Use)

Description Xavier Bachelot 2018-11-30 15:46:56 UTC
Description of problem:
The perl-lasso sub-package is missing perl provides.
The provides are not generated because perl-generators is not in the BuildRequires.

Version-Release number of selected component (if applicable):
2.6.0-8.fc29

How reproducible:
Always

Steps to Reproduce:
1. rpm -q --provides perl-lasso
2.
3.

Actual results:
$ rpm -qp --provides perl-lasso-2.6.0-7.fc29.x86_64.rpm 
perl-lasso = 2.6.0-7.fc29
perl-lasso(x86-64) = 2.6.0-7.fc29

Expected results:
$ rpm -qp --provides perl-lasso-2.6.0-8.fc29.x86_64.rpm 
perl(Lasso)
perl(Lasso::AssertionQuery)
... long list of provides ...
perl-lasso = 2.6.0-8.fc29
perl-lasso(x86-64) = 2.6.0-8.fc29

Additional info:
Adding this to the specfile is enough to fix the issue:
%if %{with_perl}
BuildRequires: perl-generators
%endif

I can file a PR if you wish.

Comment 1 Jakub Hrozek 2018-12-03 11:08:53 UTC
(In reply to Xavier Bachelot from comment #0)
> I can file a PR if you wish.

Please do, I'll merge the PR when it's available. Thank you.

Comment 2 Xavier Bachelot 2018-12-03 11:21:17 UTC
Done : https://src.fedoraproject.org/rpms/lasso/pull-request/2

Comment 3 Jakub Hrozek 2018-12-03 13:03:35 UTC
(In reply to Xavier Bachelot from comment #2)
> Done : https://src.fedoraproject.org/rpms/lasso/pull-request/2

Thank you, the PR looks good. It might be nice to keep all the BRs in one if perl block (currently around line 114) rather than adding a new if perl condition, but on the other hand there are also if python conditions..

But more importantly, John, can I get commit access to lasso? IIRC since pkgdb was retired, you can now set the access at https://src.fedoraproject.org/rpms/lasso/settings

Comment 4 Xavier Bachelot 2018-12-03 13:40:53 UTC
(In reply to Jakub Hrozek from comment #3)
> (In reply to Xavier Bachelot from comment #2)
> > Done : https://src.fedoraproject.org/rpms/lasso/pull-request/2
> 
> Thank you, the PR looks good. It might be nice to keep all the BRs in one if
> perl block (currently around line 114) rather than adding a new if perl
> condition, but on the other hand there are also if python conditions..
> 
Right, sorry about that, I did not notice the BR:s in the sub-packages. I agree consolidating them with the others BR:s would be cleaner. The sub-packages would then just keep the Requires:.
Also, there are several other cleanups that could be made:
- Remove Group: tags.
- Uppercase Url: tag and move it next to Source0: tag.
- Use %license for COPYING.
- Use %make_build in place of make %{?_smp_mflags}

Comment 5 Xavier Bachelot 2018-12-03 13:46:23 UTC
Also:
- Use %autosetup -p1 in place of %setup and %patch lines.
- Don't glob the soname to prevent unintentionnal soname bump.
- %ldconfig_scriptlets in place of the %post/postunb lines.

Again, I can submit a PR for all that, but I'd need a bit of time, feel free to beat me to it.

Comment 6 Xavier Bachelot 2018-12-03 13:48:27 UTC
And another one:
- Drop useless %attr in php-lasso sub-package.

Comment 8 Xavier Bachelot 2018-12-13 10:44:38 UTC
In case this went unnoticed, here's the PR for all of the above:
https://src.fedoraproject.org/rpms/lasso/pull-request/3

Comment 9 Jakub Hrozek 2018-12-13 13:22:40 UTC
(In reply to Xavier Bachelot from comment #8)
> In case this went unnoticed, here's the PR for all of the above:
> https://src.fedoraproject.org/rpms/lasso/pull-request/3

Thanks for the reminder, we had/have some RHEL related deadlines this and the next week, so I kind of forgot about this, but I'll try to take another look during this week.

Comment 10 Xavier Bachelot 2018-12-18 13:54:25 UTC
Thanks for merging the PR.
Any chance this can go into F29 and F28 as well ?

Comment 11 Jakub Hrozek 2018-12-18 13:57:13 UTC
(In reply to Xavier Bachelot from comment #10)
> Thanks for merging the PR.
> Any chance this can go into F29 and F28 as well ?

I can, but why? I'm not a huge fan of creating updates unless it's strictly needed. (IOW, are there any users actually hit by this issue?)

Comment 12 Xavier Bachelot 2018-12-18 14:12:50 UTC
I understand the reluctance for needless updates. Apart from me, I guess no one has hit the issue, or they would have filed a bug already.
For some context, I'm helping cleaning up the specfile for a web SSO project written in perl (https://lemonldap-ng.org) which makes use of lasso.
It's a bit cumbersome to filter the provides differently for different Fedora releases, hence the question.
https://gitlab.ow2.org/xavierb/lemonldap-ng/blob/fedora/rpm/lemonldap-ng.spec#L199
The goal would be to be able to drop all perl dependencies filtering one by one, at least for Fedora (and I'm pretty close ;-))

Comment 13 Jakub Hrozek 2018-12-18 15:07:51 UTC
Thanks for the explanation, then the update is not needless :-)

I created https://bodhi.fedoraproject.org/updates/lasso-2.6.0-10.fc29 so far. f28 ships an older version, so the patches don't apply.

Comment 14 Fedora Update System 2018-12-19 03:36:52 UTC
lasso-2.6.0-10.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-479192be35

Comment 15 Xavier Bachelot 2019-01-07 13:42:04 UTC
F28 ships an older version, but there is no soname bump between the F28 and F29 version, so F28 could be updated to the same as F29. However, the branches have diverted so it cannot be fast-forwarded.
That would also bring the perl bindings to F28, where they are currently not enabled. Your call, no strong feeling on this and I may be missing something.

Also, could you please push the F29 package to stable ?

Comment 16 Xavier Bachelot 2019-01-30 12:53:08 UTC
Hi, the package is in testing for a month now, can you please push it to stable ?

Comment 17 Jakub Hrozek 2019-01-31 08:35:39 UTC
(In reply to Xavier Bachelot from comment #16)
> Hi, the package is in testing for a month now, can you please push it to
> stable ?

Sorry about the delay, pushed.

Comment 18 Fedora Update System 2019-02-01 01:58:42 UTC
lasso-2.6.0-10.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.