Bug 1655171 - Vgs that span more than 1 device can't be zapped
Summary: Vgs that span more than 1 device can't be zapped
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Volume
Version: 3.2
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: rc
: 3.2
Assignee: Alfredo Deza
QA Contact: Parikshith
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-30 20:35 UTC by Alfredo Deza
Modified: 2019-01-03 19:02 UTC (History)
5 users (show)

Fixed In Version: RHEL: ceph-12.2.8-48.el7cp Ubuntu: ceph_12.2.8-43redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 19:02:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ceph ceph pull 25330 None None None 2018-11-30 20:45:32 UTC
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:02:36 UTC

Description Alfredo Deza 2018-11-30 20:35:36 UTC
Description of problem: When zapping and using --destroy on a VG that spans more than one device, it causes the second device to error, preventing the zap to complete.



How reproducible: Always


Steps to Reproduce:

1. create an lv that uses a vg from two devices
2. ceph-volume lvm zap --destroy vg/lv 


Actual results: A RuntimeError is raised

Comment 10 errata-xmlrpc 2019-01-03 19:02:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.