Bug 1655172 - ovirt-engine unmanaged - hosted_storage doesn't show up among configured storage domains
Summary: ovirt-engine unmanaged - hosted_storage doesn't show up among configured stor...
Keywords:
Status: CLOSED DUPLICATE of bug 1649615
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.HostedEngine
Version: 4.2.6
Hardware: x86_64
OS: Linux
unspecified
urgent vote
Target Milestone: ---
: ---
Assignee: Simone Tiraboschi
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-11-30 20:38 UTC by Dario Pulcinelli
Modified: 2018-12-03 08:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-03 08:20:44 UTC
oVirt Team: Integration


Attachments (Terms of Use)

Description Dario Pulcinelli 2018-11-30 20:38:54 UTC
Description of problem:

I've been re-deploying the engine from backup in a running cluster. All the hosts show up and the engine is deployed (hosted-engine --vm-status OK and there's a silver crown next to the host where it's deployed) but the vm is unmanaged. Tried to add a new storage domain to start the import process but that didn't work. I can control the vms and the hosts but the hosted_storage storage domain doesn't appear in the list for the DC.


Version-Release number of selected component (if applicable):


How reproducible:

every time I try to deploy


Steps to Reproduce:
1. cleanup the hosted-engine information, removing volumes andwiping out the lun
2. re-install the engine without ansible (ansible playbook fails with every configuration I've tried) and using the latest rhev-h image
3. updating the engine with yum update -y (including all the possible repositories for jboss/ovirt)
4. restoring the db, running the engine-setup and following the instructions from the script


Actual results:

hosted engine is 100% functional but not self-managed 

Expected results:

hosted_storage active and hosted-engine managed by the engine itself

Additional info:

Comment 1 Ryan Barry 2018-12-01 14:03:58 UTC
Simone, looks like a dupe of https://bugzilla.redhat.com/show_bug.cgi?id=1649615 ?

Comment 2 Simone Tiraboschi 2018-12-03 08:20:44 UTC
(In reply to Ryan Barry from comment #1)
> Simone, looks like a dupe of
> https://bugzilla.redhat.com/show_bug.cgi?id=1649615 ?

Yes, I think so.

*** This bug has been marked as a duplicate of bug 1649615 ***


Note You need to log in before you can comment on or make changes to this bug.