Bug 1655204 - /usr/share/pixmaps/apcupsd64x64.png has 0 bytes
Summary: /usr/share/pixmaps/apcupsd64x64.png has 0 bytes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: apcupsd
Version: 29
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jason Tibbitts
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-01 03:46 UTC by Boleslaw Ciesielski
Modified: 2019-01-03 05:29 UTC (History)
4 users (show)

Fixed In Version: apcupsd-3.14.14-13.fc28 apcupsd-3.14.14-13.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-13 02:47:04 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1157532 None CLOSED Application icon is too small to be used in the software center 2019-01-02 17:06:27 UTC

Description Boleslaw Ciesielski 2018-12-01 03:46:31 UTC
Description of problem:
The icon file /usr/share/pixmaps/apcupsd64x64.png included with apcupsd-gui package is empty (size 0 bytes)

Version-Release number of selected component (if applicable):
apcupsd-gui-3.14.14-12.fc29.x86_64


How reproducible:
always

Steps to Reproduce:
1. ls -l /usr/share/pixmaps/apcupsd64x64.png
2. observe reported size
3.

Actual results:
0

Expected results:
some size greater than 0

Additional info:
The icon shows up as blank in menus and panels

Comment 1 Jason Tibbitts 2018-12-03 19:40:57 UTC
Interesting; that came in well before I had anything to do with the package.  As far as I can tell, the icon file was added as a zero length file in commit 0210417761a5778e0b0981b804c321b76f4d7928and has never been changed.  I don't know what was supposed to have been in there.

As far as I can tell from the linked ticket, this, grew out of some complaint that the upstream-supplied icon was too small to be shown in the software center.  But upstream doesn't provide a larger icon that I could use.  Maybe mhlavink just intended to add an upscaled version of some existing icon, but... I don't have any easy way to tell.

I'll just assume that the intent was to have a 2x rescaled version of the existing 32x32 icon.

Comment 2 Boleslaw Ciesielski 2018-12-03 19:45:20 UTC
I don't think it makes sense to provide an upscaled version, it's not going to improve quality. If there is no larger icon then just delete this file and change /usr/share/applications/fedora-gapcmon.desktop to refer to apcupsd.png (32x32 icon) instead of apcupsd64x64.png.

Comment 3 Jason Tibbitts 2018-12-03 19:53:00 UTC
The previous issue was not about improving quality.

Comment 4 Fedora Update System 2018-12-03 20:03:18 UTC
apcupsd-3.14.14-13.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-49028afbdd

Comment 5 Fedora Update System 2018-12-03 20:03:23 UTC
apcupsd-3.14.14-13.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-56c86c26e6

Comment 6 Fedora Update System 2018-12-04 03:38:34 UTC
apcupsd-3.14.14-13.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-49028afbdd

Comment 7 Fedora Update System 2018-12-04 05:02:41 UTC
apcupsd-3.14.14-13.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-56c86c26e6

Comment 8 Nerijus Baliūnas 2018-12-04 21:29:35 UTC
rpm -ql apcupsd-gui|grep pixmaps
/usr/share/pixmaps/apcupsd.png
/usr/share/pixmaps/apcupsd64x64.png
/usr/share/pixmaps/charging.png
/usr/share/pixmaps/gapc_prefs.png
/usr/share/pixmaps/onbatt.png
/usr/share/pixmaps/online.png
/usr/share/pixmaps/unplugged.png

All these files except /usr/share/pixmaps/apcupsd64x64.png have executable permissions. Could you please fix it as well?

Comment 9 Jason Tibbitts 2018-12-04 21:33:09 UTC
That has nothing to do with the reported issue, and isn't remotely any kind of bug anyway.  The fix for this one has already been submitted and I don't see a reason to delay that.

Feel free to file a separate issue, but I won't push an update just for that.

Comment 10 Nerijus Baliūnas 2018-12-04 22:10:01 UTC
It's OK if the fix is already submitted, no need to push another update. Thanks!

Comment 11 Fedora Update System 2018-12-13 02:47:04 UTC
apcupsd-3.14.14-13.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Boleslaw Ciesielski 2018-12-23 23:57:57 UTC
This bug was reported in Fedora 29 and it's still broken. I see that the fix went into Fedora 28 but not 29. Is it going to be propagated soon?
thanks

Comment 13 Jason Tibbitts 2019-01-02 17:07:08 UTC
I don't know why the update referenced above wasn't pushed.  It certainly would have helped had you tested it and left karma, of course, bit I've asked for it to be pushed again.

Comment 14 Boleslaw Ciesielski 2019-01-03 02:44:18 UTC
I just tested on f29 and updated karma, sorry for not doing it earlier.

Comment 15 Fedora Update System 2019-01-03 05:29:14 UTC
apcupsd-3.14.14-13.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.