Bug 165524 - bad driver warnings when suspending
bad driver warnings when suspending
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FCMETA_ACPI
  Show dependency treegraph
 
Reported: 2005-08-10 01:31 EDT by petrosyan
Modified: 2015-01-04 17:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-26 18:36:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description petrosyan 2005-08-10 01:31:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
kernel gives warnings about having bad drivers when suspending the laptop.
it is a thinkpad X40.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1420_FC4

How reproducible:
Always

Steps to Reproduce:
1. suspend the laptop
  

Actual Results:  here is the output from the dmesg:
Stopping tasks: ===================================================================================================|
ACPI: PCI interrupt for device 0000:02:02.0 disabled
ACPI: PCI interrupt for device 0000:02:01.0 disabled
ACPI: PCI interrupt for device 0000:02:00.0 disabled
ACPI: PCI interrupt for device 0000:00:1f.6 disabled
ACPI: PCI interrupt for device 0000:00:1f.5 disabled
ACPI: PCI interrupt for device 0000:00:1d.7 disabled
ACPI: PCI interrupt for device 0000:00:1d.2 disabled
ACPI: PCI interrupt for device 0000:00:1d.1 disabled
ACPI: PCI interrupt for device 0000:00:1d.0 disabled
ACPI: 3 drivers with interrupt 3 neglected to call pci_disable_device at .suspend
ACPI: Fix the driver, or rmmod before suspend
ACPI: 3 drivers with interrupt 4 neglected to call pci_disable_device at .suspend
ACPI: Fix the driver, or rmmod before suspend
ACPI: 2 drivers with interrupt 5 neglected to call pci_disable_device at .suspend
ACPI: Fix the driver, or rmmod before suspend
ACPI: 1 drivers with interrupt 6 neglected to call pci_disable_device at .suspend
ACPI: Fix the driver, or rmmod before suspend
ACPI: 1 drivers with interrupt 7 neglected to call pci_disable_device at .suspend
ACPI: Fix the driver, or rmmod before suspend
ACPI: 1 drivers with interrupt 10 neglected to call pci_disable_device at .suspend
ACPI: Fix the driver, or rmmod before suspend
ACPI: 1 drivers with interrupt 11 neglected to call pci_disable_device at .suspend
ACPI: Fix the driver, or rmmod before suspend
Back to C!


Expected Results:  no warnings

Additional info:

here is my /proc/interrupts
           CPU0
  0:    2319821          XT-PIC  timer
  1:       1430          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  3:          0          XT-PIC  i915@pci:0000:00:02.0, uhci_hcd:usb2, yenta
  4:          0          XT-PIC  Intel 82801DB-ICH4 Modem, Intel 82801DB-ICH4
  5:          0          XT-PIC  uhci_hcd:usb4
  6:          1          XT-PIC  uhci_hcd:usb3
  7:       1126          XT-PIC  eth0
  8:          1          XT-PIC  rtc
  9:        184          XT-PIC  acpi
 10:      13020          XT-PIC  eth1
 11:          0          XT-PIC  ehci_hcd:usb1
 12:      27131          XT-PIC  i8042
 14:      12063          XT-PIC  ide0
NMI:          0
ERR:          0
Comment 1 Dave Jones 2005-08-26 18:36:16 EDT
Probably the usb drivers. I'd do what it suggests, and try rmmod'ing them before
you suspend.

Various suspend problems are being worked on in the FC5 tree.
Eventually these will find their way back to FC4.

In the meantime, if I were you, I'd look into using a script like pm-hibernate
to put your system into a quiet state before it suspends.
Comment 2 Myk Melez 2005-09-12 15:50:47 EDT
I see the same problem with my ThinkPad T42.  It's not USB, since removing
usb_uhci before going to sleep doesn't solve the problem (although it solves
other problems, like USB not working at all on wakeup):

/sbin/modprobe -r usb_uhci
echo -n mem > /sys/power/state
/sbin/modprobe usb_uhci

I've been looking around for pm-hibernate but can't find it (neither on my
system nor out on the web).  Anyone have a link to where I can get it?
Comment 3 Myk Melez 2005-09-12 16:01:51 EDT
Ah, here it is:

http://gnome-power.sourceforge.net/

Note You need to log in before you can comment on or make changes to this bug.