Bug 1655271 - [downstream clone - 4.2.8] Snapshot tab of a VM doesn't show any snapshots and reports java.lang.NullPointerException: html is null in UI.log
Summary: [downstream clone - 4.2.8] Snapshot tab of a VM doesn't show any snapshots an...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.2.3
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ovirt-4.2.8
: ---
Assignee: Dominik Holler
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On: 1585840
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-02 09:17 UTC by RHV Bug Bot
Modified: 2019-04-28 10:07 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1585840
Environment:
Last Closed: 2019-01-22 12:44:51 UTC
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3469151 None None None 2018-12-02 09:18:18 UTC
Red Hat Product Errata RHBA-2019:0121 None None None 2019-01-22 12:44:57 UTC
oVirt gerrit 94413 master MERGED webadmin: handle empty vNIC profile in snapshots 2018-12-02 09:18:18 UTC
oVirt gerrit 94655 ovirt-engine-4.2 MERGED webadmin: handle empty vNIC profile in snapshots 2018-12-02 09:18:18 UTC

Description RHV Bug Bot 2018-12-02 09:17:06 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1585840 +++
======================================================================

Description of problem:

A customer is not able to view the snapshots for a particular VM from the RHV GUI. The logs report exception errors. 

Version-Release number of selected component (if applicable):

ovirt-engine-4.2.3.5-0.1.el7.noarch

How reproducible:

The issue is not reproducible for all the other VM's except for one VM. 

Steps to Reproduce:

1.

2.

3.

Actual results:

The snapshot tab on GUI is empty.

Expected results:

The snapshot table should populate with all entries. 

Additional info:

(Originally by Ribu Abraham)

Comment 6 RHV Bug Bot 2018-12-02 09:17:33 UTC
Dan, this seems to be some missing NIC property? Can network team take a look if it's a valid scenario (and we should check for null) or there is some problem with NICs in snapshots?

(Originally by michal.skrivanek)

Comment 7 RHV Bug Bot 2018-12-02 09:17:38 UTC
any update on this bug ? There are no acks here as well.

(Originally by Gajanan Chakkarwar)

Comment 8 RHV Bug Bot 2018-12-02 09:17:44 UTC
restoring needinfo on Dan

(Originally by michal.skrivanek)

Comment 9 RHV Bug Bot 2018-12-02 09:17:49 UTC
moving to Network to get attention

(Originally by michal.skrivanek)

Comment 10 RHV Bug Bot 2018-12-02 09:17:54 UTC
(In reply to Michal Skrivanek from comment #4)
> Dan, this seems to be some missing NIC property? Can network team take a
> look if it's a valid scenario (and we should check for null) or there is
> some problem with NICs in snapshots?

This issue occurs if the vNIC profile is empty, which is a valid scenario and we should check for null.

(Originally by Dominik Holler)

Comment 11 RHV Bug Bot 2018-12-02 09:17:58 UTC
Reproduced on 4.2.7.2_SNAPSHOT-119.g112a042.0.scratch.master.el7ev

(Originally by Michael Burman)

Comment 12 RHV Bug Bot 2018-12-02 09:18:02 UTC
Verified upstream on - 4.2.7.3-0.0.master.20181007094930.git02c1da0.el7

(Originally by Michael Burman)

Comment 13 RHV Bug Bot 2018-12-02 09:18:07 UTC
WARN: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.2.z': '?'}', ]

For more info please contact: rhv-devops@redhat.comINFO: Bug status wasn't changed from MODIFIED to ON_QA due to the following reason:

[Found non-acked flags: '{'rhevm-4.2.z': '?'}', ]

For more info please contact: rhv-devops@redhat.com

(Originally by rhv-bugzilla-bot)

Comment 14 Michael Burman 2018-12-02 10:33:25 UTC
Verified on - 4.2.8-0.1.el7ev

Comment 16 errata-xmlrpc 2019-01-22 12:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0121


Note You need to log in before you can comment on or make changes to this bug.