Bug 1655351 - SELinux is preventing certwatch from 'write' accesses on the directory /dev/hugepages.
Summary: SELinux is preventing certwatch from 'write' accesses on the directory /dev/h...
Keywords:
Status: CLOSED DUPLICATE of bug 1655357
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:90771bce2ba2ac6817b2d31d7bc...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-03 00:37 UTC by Doug Hutcheson
Modified: 2018-12-12 14:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-12 14:34:22 UTC


Attachments (Terms of Use)

Description Doug Hutcheson 2018-12-03 00:37:39 UTC
Description of problem:
This is one of a cascade of related reports presented each morning after I open my laptop.
SELinux is preventing certwatch from 'write' accesses on the directory /dev/hugepages.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that certwatch should be allowed write access on the hugepages directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'certwatch' --raw | audit2allow -M my-certwatch
# semodule -X 300 -i my-certwatch.pp

Additional Information:
Source Context                system_u:system_r:certwatch_t:s0-s0:c0.c1023
Target Context                system_u:object_r:hugetlbfs_t:s0
Target Objects                /dev/hugepages [ dir ]
Source                        certwatch
Source Path                   certwatch
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    <Unknown>
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.19.4-300.fc29.x86_64 #1 SMP Fri
                              Nov 23 13:03:11 UTC 2018 x86_64 x86_64
Alert Count                   128
First Seen                    2018-11-26 08:56:37 AEST
Last Seen                     2018-12-03 10:08:38 AEST
Local ID                      38c8181d-2d82-4f34-ae7d-8d6ddfcc10af

Raw Audit Messages
type=AVC msg=audit(1543795718.634:10529): avc:  denied  { write } for  pid=22300 comm="certwatch" name="/" dev="hugetlbfs" ino=3521 scontext=system_u:system_r:certwatch_t:s0-s0:c0.c1023 tcontext=system_u:object_r:hugetlbfs_t:s0 tclass=dir permissive=0


Hash: certwatch,certwatch_t,hugetlbfs_t,dir,write


Additional info:
component:      selinux-policy
reporter:       libreport-2.9.6
hashmarkername: setroubleshoot
kernel:         4.19.4-300.fc29.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2018-12-12 14:34:22 UTC

*** This bug has been marked as a duplicate of bug 1655357 ***


Note You need to log in before you can comment on or make changes to this bug.