Bug 1655414 - oc get node -w with -o custom-columns, -o yaml, -o name does not "watch"
Summary: oc get node -w with -o custom-columns, -o yaml, -o name does not "watch"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.1.0
Assignee: Maciej Szulik
QA Contact: zhou ying
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-03 06:07 UTC by Kenjiro Nakayama
Modified: 2019-06-04 10:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-04 10:41:04 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:0758 None None None 2019-06-04 10:41:10 UTC

Description Kenjiro Nakayama 2018-12-03 06:07:43 UTC
Description of problem:

oc get node -w with -o custom-columns, -o yaml, -o name does not "watch".

Version-Release number of selected component (if applicable):

  oc v3.11.43
  kubernetes v1.11.0+d4cacc0
  features: Basic-Auth GSSAPI Kerberos SPNEGO

How reproducible: 100%

Steps to Reproduce:
1. Run one of following commands:

  # oc get nodes -o=custom-columns=NAME:.metadata.name,Adress:.status.addresses -w
  # oc get nodes -o name -w
  # oc get nodes -o yaml -w

Actual results:
- Got one result, but not it does not "watch".

Expected results:
- output the results some times as "watch".

Additional info:
- kubectl v1.11 (included in OCP 3.11 package reproduces same issue)
- kubectl v1.12 does not produce the issue.

Comment 1 Juan Vallejo 2018-12-04 21:38:51 UTC
This is fixed upstream in https://github.com/kubernetes/kubernetes/pull/66554.
It will be fixed in Origin once the 1.12 rebase lands.

Comment 2 Juan Vallejo 2018-12-04 21:39:34 UTC
Link to rebase PR: https://github.com/openshift/origin/pull/21450

Comment 4 zhou ying 2019-01-10 02:57:13 UTC
Confirmed with the kubect v1.12.2 , the issue has fixed, since the PR has not merged, will change status to "POST"

Comment 6 Maciej Szulik 2019-02-28 16:05:49 UTC
This was fixed along with the 1.12 rebase, moving to qa.

Comment 7 zhou ying 2019-03-01 02:24:27 UTC
The issue has fixed:

[root@preserve-master-yinzhou ~]# oc version
oc v4.0.0-0.176.0
kubernetes v1.12.4+1d3f7e4c76
features: Basic-Auth GSSAPI Kerberos SPNEGO


[root@preserve-master-yinzhou ~]# oc get nodes -o=custom-columns=NAME:.metadata.name,Adress:.status.addresses -w
NAME                                         Adress
ip-10-0-137-108.us-east-2.compute.internal   [map[address:10.0.137.108 type:InternalIP] map[type:InternalDNS address:ip-10-0-137-108.us-east-2.compute.internal] map[type:Hostname address:ip-10-0-137-108.us-east-2.compute.internal]]
ip-10-0-138-34.us-east-2.compute.internal    [map[address:10.0.138.34 type:InternalIP] map[address:ip-10-0-138-34.us-east-2.compute.internal type:InternalDNS] map[address:ip-10-0-138-34.us-east-2.compute.internal type:Hostname]]
ip-10-0-154-174.us-east-2.compute.internal   [map[type:InternalIP address:10.0.154.174] map[type:InternalDNS address:ip-10-0-154-174.us-east-2.compute.internal] map[type:Hostname address:ip-10-0-154-174.us-east-2.compute.internal]]
ip-10-0-158-15.us-east-2.compute.internal    [map[type:InternalIP address:10.0.158.15] map[type:InternalDNS address:ip-10-0-158-15.us-east-2.compute.internal] map[type:Hostname address:ip-10-0-158-15.us-east-2.compute.internal]]
ip-10-0-161-63.us-east-2.compute.internal    [map[type:InternalIP address:10.0.161.63] map[type:InternalDNS address:ip-10-0-161-63.us-east-2.compute.internal] map[type:Hostname address:ip-10-0-161-63.us-east-2.compute.internal]]
ip-10-0-173-192.us-east-2.compute.internal   [map[type:InternalIP address:10.0.173.192] map[type:InternalDNS address:ip-10-0-173-192.us-east-2.compute.internal] map[address:ip-10-0-173-192.us-east-2.compute.internal type:Hostname]]
ip-10-0-137-108.us-east-2.compute.internal   [map[type:InternalIP address:10.0.137.108] map[type:InternalDNS address:ip-10-0-137-108.us-east-2.compute.internal] map[type:Hostname address:ip-10-0-137-108.us-east-2.compute.internal]]
ip-10-0-154-174.us-east-2.compute.internal   [map[type:InternalIP address:10.0.154.174] map[type:InternalDNS address:ip-10-0-154-174.us-east-2.compute.internal] map[type:Hostname address:ip-10-0-154-174.us-east-2.compute.internal]]
ip-10-0-173-192.us-east-2.compute.internal   [map[type:InternalIP address:10.0.173.192] map[type:InternalDNS address:ip-10-0-173-192.us-east-2.compute.internal] map[type:Hostname address:ip-10-0-173-192.us-east-2.compute.internal]]
ip-10-0-158-15.us-east-2.compute.internal   [map[type:InternalIP address:10.0.158.15] map[type:InternalDNS address:ip-10-0-158-15.us-east-2.compute.internal] map[type:Hostname address:ip-10-0-158-15.us-east-2.compute.internal]]
ip-10-0-161-63.us-east-2.compute.internal   [map[type:InternalIP address:10.0.161.63] map[type:InternalDNS address:ip-10-0-161-63.us-east-2.compute.internal] map[type:Hostname address:ip-10-0-161-63.us-east-2.compute.internal]]
ip-10-0-138-34.us-east-2.compute.internal   [map[type:InternalIP address:10.0.138.34] map[type:InternalDNS address:ip-10-0-138-34.us-east-2.compute.internal] map[type:Hostname address:ip-10-0-138-34.us-east-2.compute.internal]]
ip-10-0-137-108.us-east-2.compute.internal   [map[type:InternalIP address:10.0.137.108] map[type:InternalDNS address:ip-10-0-137-108.us-east-2.compute.internal] map[type:Hostname address:ip-10-0-137-108.us-east-2.compute.internal]]
ip-10-0-154-174.us-east-2.compute.internal   [map[type:InternalIP address:10.0.154.174] map[type:InternalDNS address:ip-10-0-154-174.us-east-2.compute.internal] map[type:Hostname address:ip-10-0-154-174.us-east-2.compute.internal]]
ip-10-0-173-192.us-east-2.compute.internal   [map[type:InternalIP address:10.0.173.192] map[type:InternalDNS address:ip-10-0-173-192.us-east-2.compute.internal] map[type:Hostname address:ip-10-0-173-192.us-east-2.compute.internal]]
ip-10-0-158-15.us-east-2.compute.internal   [map[type:InternalIP address:10.0.158.15] map[type:InternalDNS address:ip-10-0-158-15.us-east-2.compute.internal] map[type:Hostname address:ip-10-0-158-15.us-east-2.compute.internal]]
^C

Comment 13 errata-xmlrpc 2019-06-04 10:41:04 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0758


Note You need to log in before you can comment on or make changes to this bug.