Bug 1655428 - Not able to see logs for block-manager user
Summary: Not able to see logs for block-manager user
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Dashboard
Version: 3.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 4.0
Assignee: Ernesto Puerta
QA Contact: Uday kurundwade
Anjana Suparna Sriram
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-03 07:16 UTC by Uday kurundwade
Modified: 2020-02-08 12:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-01-31 12:45:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of log page (39.68 KB, image/png)
2018-12-03 07:16 UTC, Uday kurundwade
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0312 0 None None None 2020-01-31 12:45:44 UTC

Description Uday kurundwade 2018-12-03 07:16:23 UTC
Created attachment 1510813 [details]
Screenshot of log page

Description of problem:
Not able to see logs for block-manager user

Version-Release number of selected component (if applicable):
ceph-common-12.2.8-43.1.el7cp.x86_64
ceph-mgr-12.2.8-43.1.el7cp.x86_64
ceph-ansible-3.2.0-0.1.rc4.el7cp.noarch

How reproducible:
Always

Steps to Reproduce:
1.Install ceph storage
2.Install "dashboard v2" by running ansible playbook
3.Login to dashboard after installation of dashboard v2
4.Create new user and assign "Block manager" role to that user. 
5.Log in with newly created Block manager user.
6.Navigate Cluster status->Logs

Actual results:
Log shows blank info

Expected results:
Log should display

Additional info:
Not able to see logs for cephfs-manager user also

Comment 5 Ernesto Puerta 2019-11-20 19:08:50 UTC
This has been fixed since 3.2. Now block-manager role does not have access to Ceph logs, only Block/RBD related configuration.

Comment 9 errata-xmlrpc 2020-01-31 12:45:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0312


Note You need to log in before you can comment on or make changes to this bug.