Bug 1655470 - Rolling update fails for task '[select a running monitor if multiple monitors]'
Summary: Rolling update fails for task '[select a running monitor if multiple monitors]'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.2
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: 3.2
Assignee: Ram Raja
QA Contact: vidushi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-03 09:01 UTC by vidushi
Modified: 2019-01-03 19:02 UTC (History)
9 users (show)

Fixed In Version: RHEL: ceph-ansible-3.2.0-0.1.rc8.el7cp Ubuntu: ceph-ansible_3.2.0~rc8-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-03 19:02:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ceph ceph-ansible pull 3413 None None None 2018-12-04 10:26:58 UTC
Red Hat Product Errata RHBA-2019:0020 None None None 2019-01-03 19:02:36 UTC

Description vidushi 2018-12-03 09:01:02 UTC
Description of problem:

Rolling update fails for task '[select a running monitor if multiple monitors]'
 
TASK [select a running monitor if multiple monitors] ************************************************************************************************************************
Monday 03 December 2018  06:16:59 +0000 (0:00:00.135)       0:02:33.577 ******* 
fatal: [magna023]: FAILED! => {"msg": "The task includes an option with an undefined variable. The error was: No last item, sequence was empty.\n\nThe error appears to have been in '/usr/share/ceph-ansible/rolling_update.yml': line 155, column 7, but may\nbe elsewhere in the file depending on the exact syntax problem.\n\nThe offending line appears to be:\n\n\n    - name: select a running monitor if multiple monitors\n      ^ here\n"}
 

Version-Release number of selected component (if applicable):
ceph-ansible-3.2.0-0.1.rc6.el7cp.noarch


How reproducible:
Always 

Steps to Reproduce:
1. Do rolling update via ansible
2. Playbook fails at task [select a running monitor if multiple monitors] 



Additional info:

Here we have used only one mon 'non-containerised' cluster for upgrade. 

So, as upgrade of a single monitor is not recommended, the play-book should ideally fail at a task say ("fail when single non containerized monitor") in the same way it errors out while rolling-update in a containerized deployment.

Comment 3 Ram Raja 2018-12-04 10:26:58 UTC
Fix is in review upstream,
https://github.com/ceph/ceph-ansible/pull/3413

Comment 12 errata-xmlrpc 2019-01-03 19:02:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0020


Note You need to log in before you can comment on or make changes to this bug.