Bug 1655474 - [Testonly] Test dnf plugin on EL7.6
Summary: [Testonly] Test dnf plugin on EL7.6
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: otopi
Classification: oVirt
Component: Plugins.packagers
Version: 1.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: ovirt-4.3.0
: ---
Assignee: Yedidyah Bar David
QA Contact: Petr Matyáš
URL:
Whiteboard:
Depends On:
Blocks: 1668685 1683580
TreeView+ depends on / blocked
 
Reported: 2018-12-03 09:08 UTC by Yedidyah Bar David
Modified: 2019-03-31 10:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-13 07:45:03 UTC
oVirt Team: Integration
rule-engine: ovirt-4.3+


Attachments (Terms of Use)

Description Yedidyah Bar David 2018-12-03 09:08:16 UTC
Description of problem:

AFAIU EL 7.6 (both RHEL and CentOS) now include a tech preview of dnf.

We should make sure that relevant tools, including engine-setup and ovirt-host-deploy, continue to work as expected when this is installed.

AFAIU, if it's installed, it's alongside yum. So e.g. 'dnf history' and 'yum history' will show different information. That's ok, users that try dnf should know what they are doing.

Comment 1 Yedidyah Bar David 2018-12-03 09:34:45 UTC
Moving to QE. For verification, please check relevant docs for how to add dnf to el 7.6, and check in the logs that indeed dnf was used, e.g. by grepping the log for 'DNF Creating transaction', and that everything worked well otherwise.

Comment 2 Sandro Bonazzola 2019-01-23 09:55:22 UTC
This has been tested by Petr and failed causing bug #1663242 to be opened.
We need to document that we doesn't support dnf on el7.6.

Comment 3 Sandro Bonazzola 2019-01-23 09:58:36 UTC
moving back to NEW having failed the test

Comment 4 Yedidyah Bar David 2019-01-23 10:43:41 UTC
bug 1663242 is about ansible code, current is about otopi. They are not really related.

Please verify current bug using only otopi-related tools (engine-setup, ovirt-host-deploy), and if you find issues, please open new bugs, and and them as dependencies for bug 1668685. Thanks.

Comment 5 Petr Matyáš 2019-01-23 10:53:27 UTC
Well then, in that case this is working as expected, I can install oVirt and run upgrade of engine.
I'm able to install a new host, however it is not possible to upgrade it at this moment, which is not an issue for otopi (will be fixed as different bug 1663242).

Engine was installed as ovirt-engine-4.3.0-0.4.master.20190101133220.git0860a07.el7.noarch and upgraded to ovirt-engine-4.3.0-0.4.master.20190102130922.gitef7445b.el7.noarch
Host was installed with vdsm-4.30.4-85.git862c9cb.el7.x86_64

Comment 6 Sandro Bonazzola 2019-02-13 07:45:03 UTC
This bugzilla is included in oVirt 4.3.0 release, published on February 4th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Comment 7 Yedidyah Bar David 2019-03-21 11:08:35 UTC
FWIW, engine-setup now failed for me. I had a CentOS machine with a few weeks old master snapshot engine set up with dnf, and did:

1. yum update

This worked, and updated engine setup packages, as well as many others. In particular, I now have:
dnf-4.0.9.2-1.el7_6.noarch
rpm-4.11.3-35.el7.x86_64

2. engine-setup
This failed with:
[ ERROR ] DNF 'Base' object has no attribute '_group_persistor'

Log has:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/otopi/context.py", line 132, in _executeMethod
    method['method']()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine-common/distro-rpm/packages.py", line 363, in _customization
    ) = self._checkForProductUpdate()
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine-common/distro-rpm/packages.py", line 239, in _checkForProductUpdate
    groups = [group['name'] for group in mpm.queryGroups()]
  File "/usr/lib/python2.7/site-packages/otopi/minidnf.py", line 820, in queryGroups
    for group in base.comps.groups_iter()
AttributeError: 'Base' object has no attribute '_group_persistor'

Briefly going through dnf git log, it seems like Base._group_persistor was removed quite some time ago [1], not sure why it failed only now - whether it's because of a rebase of dnf in CentOS 7 or a code flow we didn't go through previously.

[1] https://github.com/rpm-software-management/dnf/commit/1972a5fd27b27a03f18809699c21a83a92d35af5


Note You need to log in before you can comment on or make changes to this bug.