Bug 1655477 - Power dropdown is enabled on archived and orphaned VM's all page
Summary: Power dropdown is enabled on archived and orphaned VM's all page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.11.0
Assignee: Hilda Stastna
QA Contact: Ganesh Hubale
Red Hat CloudForms Documentation
URL:
Whiteboard:
: 1633732 (view as bug list)
Depends On:
Blocks: 1686015
TreeView+ depends on / blocked
 
Reported: 2018-12-03 09:20 UTC by Ganesh Hubale
Modified: 2019-12-13 15:16 UTC (History)
8 users (show)

Fixed In Version: 5.11.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1686015 (view as bug list)
Environment:
Last Closed: 2019-12-13 15:16:22 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Comment 2 Hilda Stastna 2018-12-18 11:28:49 UTC
Similar BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1634713

Comment 3 Martin Povolny 2019-01-10 16:36:18 UTC
Generally on the pages where there are multiple entities, such as multiple VMs you can get buttons that are not relevant.

This is a design issue and cannot be "fixed" unless you want to do a major redesign of all the GTL screens and toolbars.

The check if a particular action applies to selected entities is performed when the button is pressed. A that moment a check should be done agains the whole list of the selected items one by one.


This is how the product is designed form the very early and how all the screen behave.


I'd refer to Loic to decide if we want to be "fixing" issues like this one. I am sure we can generate a lot of similar BZs for many of the list screens.



---

In this very particular case is might be possible to have a different toolbar based on selection in the left tree --> have a different toolbar when the "Orphraned" or "Archived" tree item is selected.

I am not sure how "hacky" doing that would be.

Comment 6 Hilda Stastna 2019-01-22 14:12:23 UTC
This PR https://github.com/ManageIQ/manageiq-ui-classic/pull/5128 could be a 'fix'.
Not exactly to Expected results, but the proper flash message will be displayed if
user tries to apply some power operation on an archived/orphaned VM from the list.

Comment 7 Loic Avenel 2019-01-22 14:20:57 UTC
(In reply to Hilda Stastna from comment #6)
> This PR https://github.com/ManageIQ/manageiq-ui-classic/pull/5128 could be a
> 'fix'.
> Not exactly to Expected results, but the proper flash message will be
> displayed if
> user tries to apply some power operation on an archived/orphaned VM from the
> list.

That will help explaining that it is not possible. Best will be to remove the button..  Is it something we could do via RBAC as workaround?

Comment 8 Martin Povolny 2019-02-12 17:13:21 UTC
There's no reason the button should not behave correctly on the single item page. In this BZ I do not see the reporter complaining about that case. I assume it works correctly.


RBAC workaround: I do not think that we can remove the button from a single page with RBAC. If you remove the permission via RBAC, it should remove the button from all pages.


I think that displaying the proper flash message as Hilda suggested is the right fix. It's consistent with other places.

Comment 9 Hilda Stastna 2019-02-18 09:55:16 UTC
fixing https://github.com/ManageIQ/manageiq-ui-classic/pull/5128

Comment 10 Hilda Stastna 2019-02-22 08:37:39 UTC
*** Bug 1633732 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.