Bug 1655519 - Unable to update EAP 7.2 configuration on jdk11
Summary: Unable to update EAP 7.2 configuration on jdk11
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 7
Version: JON 3.3.11
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: CR03
: One-off release
Assignee: Michael Burman
QA Contact: Filip Brychta
URL:
Whiteboard:
Depends On:
Blocks: 1533642 1543522
TreeView+ depends on / blocked
 
Reported: 2018-12-03 11:21 UTC by Filip Brychta
Modified: 2019-01-31 15:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-31 15:54:13 UTC
Type: Bug


Attachments (Terms of Use)

Description Filip Brychta 2018-12-03 11:21:39 UTC
Description of problem:
When EAP 7.2 standalone is running on jdk11 the configuration shown in JON UI is broken due to:
The following configuration properties have invalid values: [Ext Dirs]. The values must be corrected before the configuration can be saved.

Version-Release number of selected component (if applicable):
JON 3.3.11 + EAP plugin pack 08.CR01

How reproducible:
Always

Steps to Reproduce:
1. install openjdk 11 and set JAVA_HOME env variable (e.g. export JAVA_HOME=/usr/lib/jvm/java-11-openjdk)
2. also install openjdk1.8 for agent and set RHQ_AGENT_JAVA_HOME (e.g. export RHQ_AGENT_JAVA_HOME=/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.181-7.b13.el7.x86_64/jre)
3. install/start/register agent
4. start EAP 7.2 standalone (jboss-eap-7.2/bin/standalone.sh &)
5. import the EAP from discovery queue
6. run Install RHQ User operation
7. navigate to EAP 7.2 standalone resource -> Configuration

Actual results:
Following err msg is shown in UI:
The following configuration properties have invalid values: [Ext Dirs]. The values must be corrected before the configuration can be saved.

and in agent.log:
Plugin Error: Invalid EAP7 Standalone Server Resource configuration returned by EAP7 plugin - Required property 'ext-dirs' has a null value.


Expected results:
No errors.

Additional info:
Ext Dirs property is empty which is causing the error.
When the EAP is using openjdk1.8 the property is set to:
[/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.181-7.b13.el7.x86_64/jre/lib/ext, /usr/java/packages/lib/ext]

Workaround: Configuration is saved successfully when the Ext Dirs property is set to some dummy value.

Comment 3 Michael Burman 2019-01-03 12:44:51 UTC
ext.dirs was removed and deprecated in JDK9. Setting it will prevent JDK11 from starting, so this is a value that must not be set with JDK11 installations.

Comment 4 Michael Burman 2019-01-03 13:12:34 UTC
This should be relatively safe change, in the master:

commit 458778fb09d5e17b9ad5f15c273d0a5388f418e8 (HEAD -> master)
Author: Michael Burman <miburman@redhat.com>
Date:   Thu Jan 3 15:04:23 2019 +0200

    [BZ 1655519] Make ext-dirs optional parameter in standalone server


We should probably force-delete this configuration when trying to save if we can detect JDK11 being used for the running EAP. But that's not quite as easy since we don't actively use such information elsewhere and our agent doesn't support JDK11.


Note You need to log in before you can comment on or make changes to this bug.