Bug 1655530 - Hardening tests fail for nginx
Summary: Hardening tests fail for nginx
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: nginx
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Luboš Uhliarik ✈
QA Contact: Ondřej Pták
URL:
Whiteboard:
: 1655528 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-03 11:42 UTC by Luboš Uhliarik ✈
Modified: 2019-06-14 01:52 UTC (History)
2 users (show)

Fixed In Version: nginx-1.14-820181203122130.9edba152
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-14 01:52:40 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Luboš Uhliarik ✈ 2018-12-03 11:42:31 UTC
Description of problem:
Hardening tests fail for nginx

Version-Release number of selected component (if applicable):
nginx-1.14.1-1.module+el8+2238+b017a825	

How reproducible:


Steps to Reproduce:
1. output from RPMDiff (Execshield) 
2.
3.

Actual results:
Detecting usr/lib64/perl5/vendor_perl/auto/nginx/nginx.so with not-hardened warnings '
Hardened: nginx.so: fail: (addr range: 0x17f0..0x5196): Insufficient optimization level: -O1.
Hardened: nginx.so: FAIL: The binary was compiled without sufficient optimization.
' on s390x

Expected results:
No warnings/fails

Additional info:

Comment 3 Joe Orton 2018-12-11 11:59:39 UTC
*** Bug 1655528 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.