Bug 165555 - i8kutils needs aumix (or equivalent)
i8kutils needs aumix (or equivalent)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: i8kutils (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-10 09:44 EDT by Jaime Martín Jiménez
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.25-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-24 06:43:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaime Martín Jiménez 2005-08-10 09:44:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
i8kbuttons is a daemon included in "i8kutils" to change volumen with Fn-keys in Dell Inspiron laptops.

i8kbuttons is an script that use "aumix" internally. This package is removed from Fedora Core 4 and not included in Fedora Extra:

http://fedoraproject.org/wiki/Extras/OrphanedPackages

In bug #120646:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=120646

suggess to replace "aumix" for "alsamixer" or "alsactl". Then, there are 2 solutions:

1. To include "aumix" in Fedora Extras. This is trivial because aumix rpm package from Fedora 3 works fine in Fedora 4.

2. To fix i8kbuttons from "i8kutils" package to work with "alsamixer" or "alsactl".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install "i8kutils"
2.Presh Fn-keys (multimedia buttons)


Actual Results:  Volumen doesn't change with Fn-keys in Dell laptops i8k driver compatible

Expected Results:  Volumen should to change with Fn-keys in Dell laptops i8k driver compatible

Additional info:
Comment 1 Matthias Saou 2005-08-16 09:16:12 EDT
I've just rebuilt some packages for FC-4 and development that should fix this
problem by using amixer. I've also taken the opportunity to clean up many other
details. Please try the new package once it's available and let me know if it
works as expected for you.
Comment 2 Jaime Martín Jiménez 2005-08-18 14:41:25 EDT
Fixed.

I've updated my system with yum:
i8kutils-1.25-4.fc4 from Fedora Extras uses "amixer" instead of "aumix" in
i8kbuttons script-daemon now.

Note You need to log in before you can comment on or make changes to this bug.