Bug 165556 - can't create/modify the printer configuration
can't create/modify the printer configuration
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-10 09:50 EDT by Akira TAGOH
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 0.6.141-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-11 07:28:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akira TAGOH 2005-08-10 09:50:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.11) Gecko/20050730 Epiphany/1.7.3

Description of problem:
When I press New button to create a new printer configuration, s-c-p outputs an error on the terminal like this:
Traceback (most recent call last):
  File "/usr/share/printconf/util/queueTree.py", line 581, in new_button_clicked    self.addQueue.addQueueDruid ()
  File "/usr/share/printconf/util/addQueue.py", line 277, in addQueueDruid
    window = self.window.window)
  File "/usr/share/printconf/util/queueTree.py", line 910, in populate_model_store
    models = self.conf.foomatic.make_model_dict_dict[mfr].keys ()
KeyError: 'Generic'

Also I saw similar error log with the existing printer configuration after pressing Edit button.


Version-Release number of selected component (if applicable):
system-config-printer-0.6.140-1 foomatic-3.0.2-24

How reproducible:
Always

Steps to Reproduce:
1.run system-config-printer
2.press New button
3.
  

Actual Results:  all widget becomes insensitive and can't do anything after that.

Expected Results:  dialog should be opened.

Additional info:
Comment 1 Tim Waugh 2005-08-10 10:40:54 EDT

*** This bug has been marked as a duplicate of 165328 ***
Comment 2 Tim Waugh 2005-08-11 07:28:44 EDT
Should be really fixed in 0.6.141-1.

Note You need to log in before you can comment on or make changes to this bug.