Bug 1655561 - gfid heal does not happen when there is no source brick
Summary: gfid heal does not happen when there is no source brick
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1637249
Blocks: 1655545
TreeView+ depends on / blocked
 
Reported: 2018-12-03 12:50 UTC by Ravishankar N
Modified: 2019-01-22 14:09 UTC (History)
1 user (show)

Fixed In Version: glusterfs-4.1.7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1637249
Environment:
Last Closed: 2019-01-22 14:09:20 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 21297 None None None 2018-12-03 12:50:13 UTC
Gluster.org Gerrit 21778 None Merged afr: assign gfid during name heal when no 'source' is present 2018-12-26 16:59:42 UTC

Description Ravishankar N 2018-12-03 12:50:13 UTC
+++ This bug was initially created as a clone of Bug #1637249 +++

Description of problem:

If parent dir is in split-brain or has dirty xattrs set, and the file
has gfid missing on one of the bricks, then name heal won't assign the
gfid.


Additional info:
Problem was found while trying to debug a split-brain issue on
Cynthia Zhou's setup.

--- Additional comment from Worker Ant on 2018-10-08 21:35:29 EDT ---

REVIEW: https://review.gluster.org/21297 (afr: assign gfid during name heal when no 'source' is present.) posted (#2) for review on master by Ravishankar N

--- Additional comment from Worker Ant on 2018-12-03 01:44:54 EST ---

REVIEW: https://review.gluster.org/21297 (afr: assign gfid during name heal when no 'source' is present.) posted (#13) for review on master by Pranith Kumar Karampuri

Comment 1 Worker Ant 2018-12-03 12:57:33 UTC
REVIEW: https://review.gluster.org/21778 (afr: assign gfid during name heal when no 'source' is present) posted (#1) for review on release-4.1 by Ravishankar N

Comment 2 Worker Ant 2018-12-26 16:59:41 UTC
REVIEW: https://review.gluster.org/21778 (afr: assign gfid during name heal when no 'source' is present) posted (#1) for review on release-4.1 by Ravishankar N

Comment 3 Shyamsundar 2019-01-22 14:09:20 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-4.1.7, please open a new bug report.

glusterfs-4.1.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-January/000118.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.