Bug 1655637 - setroubleshoot will not run on fresh install of Fedora 29
Summary: setroubleshoot will not run on fresh install of Fedora 29
Keywords:
Status: CLOSED DUPLICATE of bug 1641456
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: 29
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-03 15:33 UTC by Craig Goodyear
Modified: 2018-12-06 20:53 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-03 16:38:06 UTC
Type: Bug


Attachments (Terms of Use)

Description Craig Goodyear 2018-12-03 15:33:21 UTC
Description of problem:
setroubleshoot will not run on a fresh install of Fedora 29, whereas it will run if Fedora 29 was an upgrade from Fedora 28.


Version-Release number of selected component (if applicable):
setroubleshoot-3.3.18-1.fc29.x86_64

How reproducible:
every time

Steps to Reproduce:
1. try to start setroubleshoot
2.
3.

Actual results:
app does not start

Expected results:
app should run

Additional info:

output from /var/log/message during failure:

Dec  3 09:10:16 mac dbus-daemon[2605]: [session uid=1000 pid=2605] Activating service name='org.fedoraproject.Setroubleshootd' requested by ':1.641' (uid=1000 pid=31084 comm="/usr/bin/python3 -Es /usr/bin/sealert -b " label="unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023")
Dec  3 09:10:17 mac dbus-daemon[2605]: [session uid=1000 pid=2605] Successfully activated service 'org.fedoraproject.Setroubleshootd'
Dec  3 09:10:17 mac setroubleshoot.desktop[2732]: /usr/bin/sealert:32: DeprecationWarning: Importing dbus.glib to use the GLib main loop with dbus-python is deprecated.
Dec  3 09:10:17 mac setroubleshoot.desktop[2732]: Instead, use this sequence:
Dec  3 09:10:17 mac setroubleshoot.desktop[2732]:    from dbus.mainloop.glib import DBusGMainLoop
Dec  3 09:10:17 mac setroubleshoot.desktop[2732]:    DBusGMainLoop(set_as_default=True)
Dec  3 09:10:17 mac setroubleshoot.desktop[2732]:  import dbus.glib
Dec  3 09:10:18 mac dbus-daemon[1277]: [system] Activating service name='org.fedoraproject.Setroubleshootd' requested by ':1.12100' (uid=1000 pid=31088 comm="/usr/bin/python3 -Es /usr/bin/sealert -s " label="unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023") (using servicehelper)
Dec  3 09:10:18 mac dbus-daemon[1277]: [system] Activated service 'org.fedoraproject.Setroubleshootd' failed: Failed to execute program org.fedoraproject.Setroubleshootd: Permission denied
Dec  3 09:10:18 mac org.fedoraproject.Setroubleshootd[2605]: /usr/bin/sealert:32: DeprecationWarning: Importing dbus.glib to use the GLib main loop with dbus-python is deprecated.
Dec  3 09:10:18 mac org.fedoraproject.Setroubleshootd[2605]: Instead, use this sequence:
Dec  3 09:10:18 mac org.fedoraproject.Setroubleshootd[2605]:    from dbus.mainloop.glib import DBusGMainLoop
Dec  3 09:10:18 mac org.fedoraproject.Setroubleshootd[2605]:    DBusGMainLoop(set_as_default=True)
Dec  3 09:10:18 mac org.fedoraproject.Setroubleshootd[2605]:  import dbus.glib
Dec  3 09:10:18 mac org.fedoraproject.Setroubleshootd[2605]: Exception ignored in: <function SETroubleshootdDBus.__del__ at 0x7fa983445400>
Dec  3 09:10:18 mac org.fedoraproject.Setroubleshootd[2605]: Traceback (most recent call last):
Dec  3 09:10:18 mac org.fedoraproject.Setroubleshootd[2605]:  File "/usr/bin/sealert", line 279, in __del__
Dec  3 09:10:18 mac org.fedoraproject.Setroubleshootd[2605]:    s = self.iface.finish()
Dec  3 09:10:18 mac org.fedoraproject.Setroubleshootd[2605]: AttributeError: 'SETroubleshootdDBus' object has no attribute 'iface'
Dec  3 09:10:18 mac /usr/bin/sealert[31088]: could not start dbus: org.freedesktop.DBus.Error.Spawn.ExecFailed: Failed to execute program org.fedoraproject.Setroubleshootd: Permission denied

Comment 1 Petr Lautrbach 2018-12-03 16:38:06 UTC
Please run:

# dnf reinstall dbus-common dbus-daemon

*** This bug has been marked as a duplicate of bug 1641456 ***

Comment 2 Craig Goodyear 2018-12-03 19:16:00 UTC
Thank you for the reply. Reinstalling corrected the problem.

Comment 3 Kyriakos Fytrakis 2018-12-06 20:53:52 UTC
This also solved a problem with abrt on fresh install. I could not file any bug via abrt after a crash.


Note You need to log in before you can comment on or make changes to this bug.