Bug 1655737 - Re-build of redhat-release with HTB Product IDs still reports Beta/beta in /etc/os-release
Summary: Re-build of redhat-release with HTB Product IDs still reports Beta/beta in /e...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: redhat-release
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Caleigh Runge-Hottman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-03 19:38 UTC by John Sefler
Modified: 2019-02-04 21:05 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-02-04 21:05:41 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1647759 None None None 2019-06-26 10:56:31 UTC

Internal Links: 1647759

Description John Sefler 2018-12-03 19:38:51 UTC
Description of problem:

Following on to Bug 1647759... Although the redhat-release package targeted for Snapshot1 now provides the HTB product cert /etc/pki/product-default/230.pem, the PRETTY_NAME in /etc/os-release still refers to "Beta".  Expected "HTB".


Version-Release number of selected component (if applicable):
[root@dell-r730-001-guest18 ~]# rpm -q --whatprovides /etc/os-release /etc/pki/product-default/230.pem
redhat-release-8.0-0.36.el8.x86_64
redhat-release-8.0-0.36.el8.x86_64




How reproducible:


Steps to Reproduce:
[root@dell-r730-001-guest18 ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:   Red Hat Enterprise Linux for x86_64 High Touch Beta
Product ID:     230
Version:        8.0 HTB 
Arch:           x86_64
Status:         Unknown
Status Details: 
Starts:         
Ends:           

VERIFIED: THE HTB PRODUCT CERT 230 IS PROVIDED BY redhat-release AS EXPECTED FROM BUG 1647759



[root@dell-r730-001-guest18 ~]# cat /etc/os-release 
NAME="Red Hat Enterprise Linux"
VERSION="8.0 (Ootpa)"
ID="rhel"
ID_LIKE="fedora"
VERSION_ID="8.0"
PLATFORM_ID="platform:el8"
PRETTY_NAME="Red Hat Enterprise Linux 8.0 Beta (Ootpa)"
ANSI_COLOR="0;31"
CPE_NAME="cpe:/o:redhat:enterprise_linux:8.0:beta"
HOME_URL="https://www.redhat.com/"
BUG_REPORT_URL="https://bugzilla.redhat.com/"

REDHAT_BUGZILLA_PRODUCT="Red Hat Enterprise Linux 8"
REDHAT_BUGZILLA_PRODUCT_VERSION=8.0
REDHAT_SUPPORT_PRODUCT="Red Hat Enterprise Linux"
REDHAT_SUPPORT_PRODUCT_VERSION="8.0 Beta"


FAILED: FILE /etc/os-release STILL REFERS TO "Beta"/"beta" rather than "HTB"/"htb" 



Additional Info:
I suspect this is the reason why I "can not register RHEL8 HTB to Satellite 5.8 (with username/password)" if this is causing my registration to a Satellite 58 server to fail despite having the latest cdn-sync-mappings installed on my Satellite58 server and cdn-sync complete...
[root@rhsm-sat58 ~]# rpm -q cdn-sync-mappings
cdn-sync-mappings-2.30-1.el6sat.noarch
[root@rhsm-sat58 ~]# grep rhel-x86_64-baseos-8 /usr/share/rhn/cdn-sync/rhn_cdn_mappings.json
  "rhel-x86_64-baseos-8-beta": [
  "rhel-x86_64-baseos-8-beta-debuginfo": [
  "rhel-x86_64-baseos-8-htb": [
  "rhel-x86_64-baseos-8-htb-debuginfo": [
[root@rhsm-sat58 ~]# grep rhel-x86_64-baseos-8 /usr/share/rhn/cdn-sync/families.json 
      "rhel-x86_64-baseos-8-beta"
      "rhel-x86_64-baseos-8-beta-debuginfo"
      "rhel-x86_64-baseos-8-htb"
      "rhel-x86_64-baseos-8-htb-debuginfo"
[root@rhsm-sat58 ~]# grep rhel-x86_64-baseos-8 /usr/share/rhn/cdn-sync/channels.json 
    "parent_channel": "rhel-x86_64-baseos-8-beta",
    "parent_channel": "rhel-x86_64-baseos-8-beta",
    "parent_channel": "rhel-x86_64-baseos-8-htb",
    "parent_channel": "rhel-x86_64-baseos-8-htb",
  "rhel-x86_64-baseos-8-beta": {
  "rhel-x86_64-baseos-8-beta-debuginfo": {
    "parent_channel": "rhel-x86_64-baseos-8-beta",
  "rhel-x86_64-baseos-8-htb": {
  "rhel-x86_64-baseos-8-htb-debuginfo": {
    "parent_channel": "rhel-x86_64-baseos-8-htb",
    "parent_channel": "rhel-x86_64-baseos-8-beta",
    "parent_channel": "rhel-x86_64-baseos-8-beta",
    "parent_channel": "rhel-x86_64-baseos-8-htb",
    "parent_channel": "rhel-x86_64-baseos-8-htb",
    "parent_channel": "rhel-x86_64-baseos-8-beta",
    "parent_channel": "rhel-x86_64-baseos-8-beta",
    "parent_channel": "rhel-x86_64-baseos-8-htb",
    "parent_channel": "rhel-x86_64-baseos-8-htb",
    "parent_channel": "rhel-x86_64-baseos-8-beta",
    "parent_channel": "rhel-x86_64-baseos-8-beta",
    "parent_channel": "rhel-x86_64-baseos-8-htb",
    "parent_channel": "rhel-x86_64-baseos-8-htb",
    "parent_channel": "rhel-x86_64-baseos-8-beta",
    "parent_channel": "rhel-x86_64-baseos-8-beta",
    "parent_channel": "rhel-x86_64-baseos-8-htb",
    "parent_channel": "rhel-x86_64-baseos-8-htb",
    "parent_channel": "rhel-x86_64-baseos-8-beta",
    "parent_channel": "rhel-x86_64-baseos-8-beta",
[root@rhsm-sat58 ~]# 


FAILING REGISTRATION TO SATELLIT58...
[root@dell-r730-001-guest18 ~]# rhnreg_ks --serverUrl=https://rhsm-sat58.usersys.redhat.com/XMLRPC --username=rhsm-client --password=REDACTED
rhn-plugin: Error communicating with server. The message was:

Error Class Code: 70
Error Class Info: 
     All available subscriptions for the requested channel have been exhausted.
     Please contact a Red Hat Satellite Sales associate.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.

[root@dell-r730-001-guest18 ~]#


Note You need to log in before you can comment on or make changes to this bug.