Bug 1655740 - fixed_key value is logged in the nova logs
Summary: fixed_key value is logged in the nova logs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 10.0 (Newton)
Hardware: x86_64
OS: All
low
medium
Target Milestone: z1
: 14.0 (Rocky)
Assignee: Lee Yarwood
QA Contact: nova-maint
URL:
Whiteboard:
Depends On:
Blocks: 1657275 1657276
TreeView+ depends on / blocked
 
Reported: 2018-12-03 19:46 UTC by David Hill
Modified: 2019-09-09 16:10 UTC (History)
10 users (show)

Fixed In Version: openstack-nova-18.0.3-0.20181011032841.d1243fe.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1657275 (view as bug list)
Environment:
Last Closed: 2019-03-18 13:02:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1806471 None None None 2018-12-03 19:47:36 UTC
OpenStack gerrit 621684 None None None 2018-12-04 18:39:06 UTC
Red Hat Product Errata RHBA-2019:0592 None None None 2019-03-18 13:02:21 UTC

Description David Hill 2018-12-03 19:46:08 UTC
Description of problem:
fixed_key value is logged in the nova logs

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set fixed_key value
2.
3.

Actual results:
It's logged in the logs

Expected results:
It shouldn't be logged

Additional info:

Comment 1 Lee Yarwood 2018-12-06 17:31:32 UTC
Lowering this to medium/medium as fixed_key isn't supported in production environments. The fact that we log the key during start up is the least of the issues with using it but never the less it should be removed. I'll pull this down into OSP 10 once it starts to land upstream.

Comment 6 errata-xmlrpc 2019-03-18 13:02:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0592


Note You need to log in before you can comment on or make changes to this bug.