Bug 1655777 - SELinux is preventing sss_cache from 'write' accesses on the directory /var/lib/sss/db.
Summary: SELinux is preventing sss_cache from 'write' accesses on the directory /var/l...
Keywords:
Status: CLOSED DUPLICATE of bug 1640255
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:78d231115361afb155b22066958...
: 1655780 1656577 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-03 21:53 UTC by Modestas
Modified: 2018-12-07 13:21 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-07 13:21:28 UTC


Attachments (Terms of Use)

Description Modestas 2018-12-03 21:53:53 UTC
Description of problem:
SELinux is preventing sss_cache from 'write' accesses on the directory /var/lib/sss/db.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that sss_cache should be allowed write access on the db directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'sss_cache' --raw | audit2allow -M my-ssscache
# semodule -X 300 -i my-ssscache.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:groupadd_t:s0-s0:c0.c102
                              3
Target Context                system_u:object_r:sssd_var_lib_t:s0
Target Objects                /var/lib/sss/db [ dir ]
Source                        sss_cache
Source Path                   sss_cache
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           sssd-common-1.16.3-2.fc28.x86_64
Policy RPM                    selinux-policy-3.14.1-48.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.18.18-200.fc28.x86_64 #1 SMP Mon
                              Nov 12 03:17:32 UTC 2018 x86_64 x86_64
Alert Count                   2
First Seen                    2018-12-02 11:29:19 EET
Last Seen                     2018-12-02 11:29:19 EET
Local ID                      7810897b-b8a5-4ea7-9f76-51fc0c6dac42

Raw Audit Messages
type=AVC msg=audit(1543742959.687:591): avc:  denied  { write } for  pid=7604 comm="sss_cache" name="db" dev="dm-1" ino=1975299 scontext=unconfined_u:unconfined_r:groupadd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:sssd_var_lib_t:s0 tclass=dir permissive=0


Hash: sss_cache,groupadd_t,sssd_var_lib_t,dir,write

Version-Release number of selected component:
selinux-policy-3.14.1-48.fc28.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.6
hashmarkername: setroubleshoot
kernel:         4.19.5-200.fc28.x86_64
type:           libreport

Comment 1 Modestas 2018-12-03 22:00:22 UTC
*** Bug 1655780 has been marked as a duplicate of this bug. ***

Comment 2 Jean-Baptiste 2018-12-05 18:32:54 UTC
*** Bug 1656577 has been marked as a duplicate of this bug. ***

Comment 3 Lukas Slebodnik 2018-12-07 13:21:28 UTC

*** This bug has been marked as a duplicate of bug 1640255 ***


Note You need to log in before you can comment on or make changes to this bug.