Bug 165585 - LVM2 snap shots corrupt MD-RAID1
LVM2 snap shots corrupt MD-RAID1
Status: CLOSED DUPLICATE of bug 159749
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-10 12:33 EDT by John Rydberg
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-10 12:36:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Rydberg 2005-08-10 12:33:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
After creating a snap shot of the root LVM2 volume on a MD-RAID1 IDE drives, common commands fail with "cannot execute binary".  This happens when trying to use commands like tar or mke2fs or even top and clear, after mounting the snap shot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create fresh install of FC4 onto an IDE MD-RAID1 drive set.  Drive configuration like this: /dev/md0 = /dev/hda1 + /dev/hdc1 (100MB) EXT2 (/boot) and  /dev/md1 = /dev/hda2 + /dev/hdc2 (200GB) LVM.  Create / during install of 4096MB as /dev/vg0/root.  Reboot after install and login as normal root user.
 
2. Create a Backup Volume: lvcreate -L20GB -n /dev/vg0/Backup prepare as EXT3 and mount this volume, /mnt/Backup.
  
3. Create a snap shot of active root volume: lvcreate -L200M -s -n snap /dev/vg0/root and mount this volume, /mnt/snap.

4. Now try to backup up /mnt/snap to /mnt/Backup: tar -czf /mnt/Backup/root.tgz   /mnt/snap 
  

Actual Results:  As soon as you try to run tar, you will get the error "cannot execute binary".  Most every command will begin to fail, including "shutdown -h now" with the same error.

Expected Results:  Normally the backup of a snap shot using tar should run as expected.  It is good practice to backup before major system changes and LVM snap shots is a great way to do this. 

Additional info:

This issue does not occur in non-MD-RAID IDE systems. I do this all the time on single drive systems including my laptop.  I think there must be some conflict with the way LVM freezes the blocks that screws up MD RAID.
Comment 1 Alasdair Kergon 2005-08-10 12:36:59 EDT

*** This bug has been marked as a duplicate of 159749 ***

Note You need to log in before you can comment on or make changes to this bug.