Bug 1655927 - Subscription details should show "Catalog Source" not "Catalog" in table
Summary: Subscription details should show "Catalog Source" not "Catalog" in table
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.1.0
Assignee: Alec Merdler
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-04 09:28 UTC by Yadan Pei
Modified: 2019-03-12 14:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-01-11 19:17:20 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yadan Pei 2018-12-04 09:28:10 UTC
Description of problem:
in Subscription details page, CatalogSource is shown as "CATALOG"

Version-Release number of selected component (if applicable):
openshift v4.0.0-0.79.0

How reproducible:
Always

Steps to Reproduce:
1.Enable OLM in the cluster
2.Cluster admin login to cluster console, go to Package Manifests -> create Subscription for etcd
3.Go to Subscritpions -> etcd-*** to see its details

Actual results:
3. There is a column "CATALOG" with value "rh-operators"

Expected results:
3. To be more precious, it should be "CATALOG SOURCE" since 'rh-operators' is CatalogSource resource.

Additional info:

Comment 1 Alec Merdler 2018-12-10 21:37:36 UTC
https://github.com/openshift/console/pull/918

Comment 2 Yadan Pei 2019-01-10 07:32:31 UTC
Subscriptions Details table use "CATALOG SOURCE" instead of 'CATALOG' now


Verified on
registry.svc.ci.openshift.org/openshift/origin-v4.0-2019-01-10-044754@sha256   ab9cd0df895b7ab74594d33a68c87443609bd8b1a1327f0de2044f470318f4d7   a71164a46db0   3 hours ago         268 MB
with commit afbc04657d94682d5ec15a0146ac4a8e7da692da


Note You need to log in before you can comment on or make changes to this bug.