Bug 1655971 - `oc rsh` fail with oci error "connection reset by peer" and `oc exec` without `-it` has panic
Summary: `oc rsh` fail with oci error "connection reset by peer" and `oc exec` withou...
Keywords:
Status: CLOSED DUPLICATE of bug 1655214
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.9.z
Assignee: Mrunal Patel
QA Contact: weiwei jiang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-04 10:48 UTC by Xingxing Xia
Modified: 2018-12-05 02:59 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-04 22:10:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3734981 None None None 2018-12-04 15:28:00 UTC

Description Xingxing Xia 2018-12-04 10:48:27 UTC
Description of problem:
`oc rsh` fail with oci error "connection reset by peer"  and `oc exec` without `-it` has panic

Version-Release number of selected component (if applicable):
v3.9.57

How reproducible:
Always

Steps to Reproduce:
1. oc new-project xxia-proj
oc new-app openshift/mysql-55-centos7:latest --name=database --env=MYSQL_USER=user1 --env=MYSQL_PASSWORD=password1 MYSQL_DATABASE=mydb
oc create -f https://raw.githubusercontent.com/openshift-qe/v3-testfiles/master/pods/pod_with_two_containers.json

oc get pod
NAME               READY     STATUS    RESTARTS   AGE
database-1-wdtkz   1/1       Running   0          16m
doublecontainers   2/2       Running   0          19m

2. oc rsh database-1-wdtkz
rpc error: code = 2 desc = oci runtime error: exec failed: container_linux.go:247: starting container process caused "process_linux.go:110: decoding init error from pipe caused \"read parent: connection reset by peer\""
command terminated with exit code 126

oc rsh doublecontainers echo my_test_string
Defaulting container name to hello-openshift.
Use 'oc describe pod/doublecontainers -n xxia-proj' to see all of the containers in this pod.
exec failed: container_linux.go:336: starting container process caused "read init-p: connection reset by peer"
command terminated with exit code 1

3. oc exec database-1-wdtkz echo test
panic: boringcrypto: not in FIPS mode

goroutine 1 [running]:
crypto/internal/boring.init.0()
	/opt/rh/go-toolset-7/root/usr/lib/go-toolset-7-golang/src/crypto/internal/boring/boring.go:35 +0xd6
exec failed: container_linux.go:336: starting container process caused "read init-p: connection reset by peer"


oc exec -it database-1-wdtkz sh
exec failed: container_linux.go:336: starting container process caused "read init-p: connection reset by peer"
command terminated with exit code 1

Actual results:
2. `oc rsh` has error
3. `oc exec` without `-it` has panic

Expected results:
2 and 3: Should succeed

Additional info:

Comment 2 Arnab Ghosh 2018-12-04 12:41:51 UTC
Customer is facing issue after upgrading docker to version docker-1.13.1-84.git07f3374.el7.x86_64.

$ oc rsh tollkreditt-endring-rf1344-102-bv2nh
rpc error: code = 2 desc = oci runtime error: exec failed: container_linux.go:247: starting container process caused "process_linux.go:110: decoding init error from pipe caused \"read parent: connection reset by peer\""

$ oc exec -ti  tollkreditt-endring-rf1344-102-bv2nh sh 
rpc error: code = 2 desc = oci runtime error: exec failed: container_linux.go:247: starting container process caused "process_linux.go:110: decoding init error from pipe caused \"read parent: connection reset by peer\""

The issue seem to be resolved after downgrading to docker-1.13.1-75

Comment 5 Jan Pazdziora 2018-12-04 15:41:01 UTC
This looks like duplicate of bug 1655214.

Comment 6 Juan Vallejo 2018-12-04 22:10:16 UTC

*** This bug has been marked as a duplicate of bug 1655214 ***


Note You need to log in before you can comment on or make changes to this bug.