RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1655975 - docker exec command is failing for Ubuntu , busybox containers
Summary: docker exec command is failing for Ubuntu , busybox containers
Keywords:
Status: CLOSED DUPLICATE of bug 1655214
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker
Version: 7.6
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Daniel Walsh
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-04 10:54 UTC by Lalatendu Mohanty
Modified: 2022-03-13 16:20 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-04 21:12:23 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3734981 0 None None None 2018-12-04 15:28:48 UTC

Description Lalatendu Mohanty 2018-12-04 10:54:56 UTC
Description of problem:

docker exec command on Ubuntu container is failing.

However, it works fine on CentOS container inages

Version-Release number of selected component (if applicable):
docker 1.13.1-84.git07f3374 (RPM version i.e. rpm -qa | grep docker)

How reproducible:

Always

Steps to Reproduce:
On RHEL 7.6 run following commands

1. docker run -ti --rm ubuntu bash
2. Open a new tab 
3. run the "docker ps" command and note the container ID for the Ubuntu container
4. Run "docker exec -ti <Container ID> bash"

Actual results:

$ docker exec -ti 015c6ad3c816 bash

rpc error: code = 2 desc = oci runtime error: exec failed: container_linux.go:247: starting container process caused "process_linux.go:110: decoding init error from pipe caused \"read parent: connection reset by peer\""




Expected results:

docker exec command should run without any issue

Additional info:

The issue is coming with docker 1.13.1-84.git07f3374 (RPM version), but we cannot reproduce the same issue with docker 1.13.1-75.git8633870. 

We got this while testing latest CDK build based on latest RHEL 7 : https://issues.jboss.org/browse/CDK-380

There is an existing Origin issue on this https://github.com/openshift/origin/issues/21590

Comment 2 Lalatendu Mohanty 2018-12-04 11:06:27 UTC
It is also failing for busybox

$ docker run -ti --rm busybox sh 

In a new shell 
$ docker exec -ti 55d7f58509b6 sh  
rpc error: code = 2 desc = oci runtime error: exec failed: container_linux.go:247: starting container process caused "process_linux.go:110: decoding init error from pipe caused \"read parent: connection reset by peer\""

Comment 3 Ruben Vermeersch 2018-12-04 12:08:24 UTC
This breaks all Kubernetes clusters as well, so pretty critical!

Comment 4 Jan Pazdziora 2018-12-04 15:41:05 UTC
This looks like duplicate of bug 1655214.

Comment 5 Derrick Ornelas 2018-12-04 21:12:23 UTC

*** This bug has been marked as a duplicate of bug 1655214 ***


Note You need to log in before you can comment on or make changes to this bug.