Bug 1655980 - Unable to update configuration of Broadcast Group
Summary: Unable to update configuration of Broadcast Group
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 7
Version: JON 3.3.11
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: CR01
: One-off release
Assignee: Josejulio Martínez
QA Contact: Filip Brychta
URL:
Whiteboard:
Depends On:
Blocks: 1657856
TreeView+ depends on / blocked
 
Reported: 2018-12-04 11:16 UTC by Filip Brychta
Modified: 2019-05-16 09:27 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-16 09:27:31 UTC
Type: Bug


Attachments (Terms of Use)

Description Filip Brychta 2018-12-04 11:16:03 UTC
Description of problem:
Attempt to update configuration of Broadcast Group fails for several reasons:
- Socket Binding is incorectly marked as required
- jgroups-cluster is invalid in combination with socket-binding

jgroups-cluster is not even available in JON UI.

Version-Release number of selected component (if applicable):
JON 3.3.11 + EAP plugin pack 08.CR01

How reproducible:
Always

Steps to Reproduce:
1. start EAP 7 domain mode
2. import the EAP 7 from discovery queue
3. run Add management user operation
4. navigate to EAP 7 Domain Controller->Profiles->full-ha->Subsystems->messaging-activemq->default->bg-group1->Configuration
5. set Socket Binding to test
7. save

Actual results:
After step 4:
The following configuration properties have invalid values: [Socket Binding]. The values must be corrected before the configuration can be saved.

Which is not correct because Socket Binding is no longer required (see /profile=full-ha/subsystem=messaging-activemq/server=default/broadcast-group=bg-group1:read-resource-description
)

After step 7:
{domain-failure-description={WFLYCTL0062: Composite operation failed and was rolled back. Steps that failed:={Operation step-3=WFLYCTL0105: jgroups-cluster is invalid in combination with socket-binding}}}, rolled-back=true

But jgroups-cluster property is not even available in JON UI.

Expected results:
Configuration properties should be up to date and configuration update should be successful.

Additional info:
Tried on EAP 7.2 and EAP 7.1
This should also affect Broadcast Group resource type for EAP standalone

Comment 5 Josejulio Martínez 2019-04-11 16:12:36 UTC
commit ba9da4c8b706e8c4efb36a9f4d19f2d061b139a3
Author: Josejulio Martínez <jmartine@redhat.com>
Date:   Tue Apr 9 16:37:28 2019 -0500

    Bug 1655980 - Adds jgroups-* configuration to Broadcast Group

Comment 14 Sunil Kondkar 2019-04-30 15:20:59 UTC
Tested on 3.3 EAP Plugin Pack Update 09

For EAP7.2:
The config update is failing on EAP7.2 with below message:
{domain-failure-description={WFLYCTL0062: Composite operation failed and was rolled back. Steps that failed:={Operation step-6=WFLYCTL0105: jgroups-cluster is invalid in combination with socket-binding}}}, rolled-back=true

Additional Info:
The default value displayed in property 'jgroups channel' is 'activemq-cluster'
If we unset the the property 'jgroups channel' and enter value 'test' for property 'socket binding', after clicking 'Save', the config update is successful.

For EAP7.1.6:

The config update is failing on EAP7.1.6 with below message:
{domain-failure-description={WFLYCTL0062: Composite operation failed and was rolled back. Steps that failed:={Operation step-4=WFLYCTL0201: Unknown attribute 'jgroups-cluster'}}}, rolled-back=true

Additional Info:
The default value displayed in property 'jgroups channel' is 'activemq-cluster'
If we unset the the property 'jgroups channel' and enter value 'test' for property 'socket binding', after clicking 'Save', the config update is still failing with message:
{domain-failure-description={WFLYCTL0062: Composite operation failed and was rolled back. Steps that failed:={Operation step-4=WFLYCTL0201: Unknown attribute 'jgroups-cluster'}}}, rolled-back=true

Comment 16 Sunil Kondkar 2019-05-02 02:50:49 UTC
Verified on 3.3 EAP Plugin Pack Update 09 CR02

For EAP7.2 and For EAP7.1.6:

The default value displayed in property 'jgroups channel' is 'activemq-cluster'
If we unset the the property 'jgroups channel' and enter value 'test' for property 'socket binding', after clicking 'Save', the config update is successful.


Note You need to log in before you can comment on or make changes to this bug.