Bug 165599 - php-mysql unable to install depandency error
php-mysql unable to install depandency error
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: php (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-10 14:09 EDT by Ali Firdos
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 05:42:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ali Firdos 2005-08-10 14:09:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.10) Gecko/20050719 Red Hat/1.7.10-1.1.3.1

Description of problem:
When Adding php-mysql module from Package Management, I get a dependacy error like the following:
The following packages could not be found on your system.  Installation cannot continue until they are installed.

Unlocaatable package  |  Required by
php                      ('php-ldap', '4.3.2', '24.ent')
php                      ('php-imap', '4.3.2', '24.ent')

When I try to figure out what rpms that have been installed previously I see the following:
$ rpm -qa | grep php
php-ldap-4.3.2-24.ent
php-4.3.2-24.ent
php-imap-4.3.2-24.ent

It is evident that php exists along with ldap and imap.  I can't seem to figure out why there is a dependancy error.  

Version-Release number of selected component (if applicable):
php-mysql

How reproducible:
Always

Steps to Reproduce:
1. When adding php-mysql module
2.
3.
  

Actual Results:  I get a dependacy error

Expected Results:  Should install php-mysql module

Additional info:
Comment 1 Suzanne Hillman 2005-08-11 10:52:17 EDT
What tool are you using for Package Management? And, if you try to up2date from
the command line, does the same thing happen?
Comment 2 Ali Firdos 2005-08-11 12:34:49 EDT
Well I tried the following to solve it.  I removed the packages php-ldap-4.3.2-
24.ent and php-imap-4.3.2-24.ent.  I don't get a dependancy error anymore.  
What I had to do than was to remove php-4.3.2-24.ent, because the Redhat CD 
contained php-mysql-4.3.2-11.ent.x86_64.rpm and not compatible with 4.3.2.  
Once I had no modules of php installed on my system, I installed php-4.3.2-
11.xxx and installed the php-mysql module.  Everything was fine until I 
realized that installing the above rpms, my jvm was being pointed by redhat 
somewhere else and not the one I installed from Sun.  I wonder if Redhat knows 
of this.  I don't seem to know why installing php and php-mysql would change 
where my jre and jdk were pointing.  I had to reconfigure the system to point 
to the right JDK and JRE.  The odd thing is that I ran up2Date so that I get 
the new versions from php and php-mysql and  I don't get the JRE versioning 
problem anymore, so that is a good thing!
Comment 3 Ali Firdos 2005-08-11 16:07:18 EDT
Ok, I am sorry I jumped too quickly.  I ended up having other errors within php
that state the following: 
"Warning: mysql_connect(): Client does not support authentication protocol
requested by server; consider upgrading MySQL client"
The only reason when I installed it worked fine is because
mysql-3.23.58-16.RHEL3.1.x86_64.rpm was already installed.  I had to remove the
mysql-3.23.xx because it was too old and the client was also too old and not
compatible with our server that contains the
MySQL-server-standard-4.1.13-0.rhel3.x86_64.rpm.  Now when I try to install
php-mysql, I get a complaint stating the following:

error: Failed dependencies:
        libmysqlclient.so.10()(64bit) is needed by php-mysql-4.3.2-11.ent
        php = 4.3.2-11.ent is needed by php-mysql-4.3.2-11.ent
    Suggested resolutions:
        /mysql-3.23.58-16.RHEL3.1.x86_64.rpm

How do I find the correct php-mysql and php that is compatable to my system and
that will work?  Please help me out, I have been trying this for days with the
results getting worst and worst.  
Comment 4 Ali Firdos 2005-08-12 12:48:10 EDT
I don't seem to be getting any response, it could be my fault.  I apologize for
not being clear enough.  Here is the problem again:

Both database server and webserver OS: Redhat ES 3 x86 64

Database server: It had the old mysql-3.23 preinstalled, but we had to update it
to the latest 4.1.13 version for the new functionality.  I had to remove the old
one and install the new one.  Done!  No problems with anything.

Web server: It had the old mysql-3.23 preinstalled with Apache and php.  I had
to manually install the php-mysql module.  I did and no problems, except when I
was trying to use mysql_connect() method of php, it complained stating the
client was too old and I would have to update the client version of mysql.  I
tried and ofcourse it would fail because I had mysql-3.23 installed.  I had to
uninstall the old mysql-3.23.  I had to uninstall php and php-mysql.  I went to
mysql.com and downloaded the following rpms and installed:
MySQL-client-standard-4.1.13-0.rhel3.x86_64.rpm
MySQL-devel-standard-4.1.13-0.rhel3.x86_64.rpm
MySQL-shared-standard-4.1.13-0.rhel3.x86_64.rpm
Ok now, so far so good.  I installed php-4.3.2-11.ent.x86_64.rpm.  Still no
problem.  Finally I tried to install php-mysql-4.3.2-11.ent.x86_64.rpm and than
I get an error stating the following:
error: Failed dependencies:
        libmysqlclient.so.10()(64bit) is needed by php-mysql-4.3.2-11.ent
        php = 4.3.2-11.ent is needed by php-mysql-4.3.2-11.ent
    Suggested resolutions:
        /mysql-3.23.58-16.RHEL3.1.x86_64.rpm
I have searched everywhere, the only solution that I seem to find is that I have
to install the MySQL-shared rpm.  I have already done so!  Please I beg someone
to help me out.  It is driving me nuts!  I kindly request for help, please!

Comment 5 Joe Orton 2005-08-15 05:42:58 EDT
For support using packages downloaded from mysql.com I'd suggest you contact
MySQL rather than Red Hat; perhaps try using the RHEL3 community support list,
taroon-list@redhat.com.

If you need further assistance please contant Red Hat Technical Support at
888-REDHAT-1 or file a web ticket at http://www.redhat.com/apps/support/.

Note You need to log in before you can comment on or make changes to this bug.