Bug 1655998 - [abrt] xorg-x11-server-Xwayland: OsLookupColor(): Segmentation fault at address 0x0
Summary: [abrt] xorg-x11-server-Xwayland: OsLookupColor(): Segmentation fault at addre...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: 29
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e354ebcabbb487ceb4d4c26fe13...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-04 12:02 UTC by Jesper Skov
Modified: 2018-12-19 02:28 UTC (History)
9 users (show)

Fixed In Version: xorg-x11-server-1.20.3-2.fc29
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-12-19 02:28:13 UTC


Attachments (Terms of Use)
File: backtrace (498 bytes, text/plain)
2018-12-04 12:02 UTC, Jesper Skov
no flags Details
File: cpuinfo (1.42 KB, text/plain)
2018-12-04 12:02 UTC, Jesper Skov
no flags Details
File: dmesg (65.91 KB, text/plain)
2018-12-04 12:02 UTC, Jesper Skov
no flags Details
File: dso_list (240 bytes, text/plain)
2018-12-04 12:02 UTC, Jesper Skov
no flags Details
File: etc_X11_xorg_conf_d.tar.gz (366 bytes, application/octet-stream)
2018-12-04 12:02 UTC, Jesper Skov
no flags Details
File: usr_share_xorg_conf_d.tar.gz (1.92 KB, application/octet-stream)
2018-12-04 12:02 UTC, Jesper Skov
no flags Details

Description Jesper Skov 2018-12-04 12:02:32 UTC
Description of problem:
The problem is triggered (sometimes) when I use an external (DisplayPort) KVM-switch.

The crash appears (I think) more frequently, if I switch when the display is on.
I have taken to locking the screen before I switch over, as this appears to reduce the problem frequency.

I experienced the crash (same symptoms, anyway) a few time with F28. 
After upgrading to F29 it happens daily.

Version-Release number of selected component:
xorg-x11-server-Xwayland-1.20.3-1.fc29

Additional info:
reporter:       libreport-2.9.6
crash_function: OsLookupColor
executable:     /usr/bin/Xwayland
kernel:         4.19.5-300.fc29.x86_64
runlevel:       N 5
type:           xorg
uid:            0

Truncated backtrace:
0: /usr/bin/Xwayland (OsLookupColor+0x13d) [0x5598d52121ed]
1: /lib64/libpthread.so.0 (funlockfile+0x50) [0x7fdad26120bf]
2: /usr/bin/Xwayland (present_wnmd_event_notify+0x3e1) [0x5598d517a341]
3: /usr/bin/Xwayland (present_can_window_flip+0xb9e) [0x5598d517b87e]
4: /usr/bin/Xwayland (SendErrorToClient+0x35e) [0x5598d51dc21e]
5: /usr/bin/Xwayland (InitFonts+0x3c6) [0x5598d51e0246]
6: /lib64/libc.so.6 (__libc_start_main+0xf3) [0x7fdad245d413]
7: /usr/bin/Xwayland (_start+0x2e) [0x5598d50ae35e]

Comment 1 Jesper Skov 2018-12-04 12:02:36 UTC
Created attachment 1511273 [details]
File: backtrace

Comment 2 Jesper Skov 2018-12-04 12:02:38 UTC
Created attachment 1511274 [details]
File: cpuinfo

Comment 3 Jesper Skov 2018-12-04 12:02:42 UTC
Created attachment 1511275 [details]
File: dmesg

Comment 4 Jesper Skov 2018-12-04 12:02:44 UTC
Created attachment 1511276 [details]
File: dso_list

Comment 5 Jesper Skov 2018-12-04 12:02:46 UTC
Created attachment 1511277 [details]
File: etc_X11_xorg_conf_d.tar.gz

Comment 6 Jesper Skov 2018-12-04 12:02:47 UTC
Created attachment 1511278 [details]
File: usr_share_xorg_conf_d.tar.gz

Comment 7 Fedora Update System 2018-12-18 02:12:07 UTC
xorg-x11-server-1.20.3-2.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-e3ade0ccc7

Comment 8 Fedora Update System 2018-12-19 02:28:13 UTC
xorg-x11-server-1.20.3-2.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.