Bug 1656007 - remove Cirrus graphics support
Summary: remove Cirrus graphics support
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high vote
Target Milestone: ovirt-4.3.1
: ---
Assignee: Michal Skrivanek
QA Contact: meital avital
Rolfe Dlugy-Hegwer
URL:
Whiteboard:
: 1655452 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-04 12:46 UTC by Michal Skrivanek
Modified: 2019-04-11 10:08 UTC (History)
7 users (show)

Fixed In Version: ovirt-engine-4.3.0_rc
Doc Type: Removed functionality
Doc Text:
Support for Cirrus graphics cards in guest operating systems was deprecated in version 4.0 and is no longer supported in 4.3 cluster levels. In this release, the "Cirrus" option has been removed from the "Video Type" setting in the Administration Portal.
Clone Of:
Environment:
Last Closed: 2019-03-13 16:39:33 UTC
oVirt Team: Virt
rule-engine: ovirt-4.3+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 95993 'None' 'MERGED' 'core: remove cirrus display from 4.3' 2019-11-11 14:26:22 UTC
oVirt gerrit 97176 'None' 'ABANDONED' 'core: remove cirrus from instance types' 2019-11-11 14:26:22 UTC
oVirt gerrit 97969 'None' 'MERGED' 'core: change cirrus display to vga in 4.3 upgrade' 2019-11-11 14:26:22 UTC

Description Michal Skrivanek 2018-12-04 12:46:39 UTC
Cirrus is deprecated since 4.0 and VGA is the new default. In 4.3 we're dropping 3.6 compatibility and so we can remove Cirrus completely

Comment 1 Michal Skrivanek 2018-12-04 12:48:46 UTC
*** Bug 1655452 has been marked as a duplicate of this bug. ***

Comment 2 Michal Skrivanek 2018-12-05 07:58:03 UTC
"almost completely", as it was left as allowed in 4.0-4.2. So just changing the defaults

Comment 3 Rolfe Dlugy-Hegwer 2019-01-17 22:47:18 UTC
Please tech review the updated Doc Text.

Comment 4 Michal Skrivanek 2019-01-18 07:38:20 UTC
looks good

Comment 5 meital avital 2019-01-21 18:15:02 UTC
Cirrus graphics option visible in Instance Type

Comment 6 Michal Skrivanek 2019-02-21 14:09:06 UTC
(In reply to meital avital from comment #5)
> Cirrus graphics option visible in Instance Type

note it doesn't let you create VMs with Cirrus anyway, so it's just a cosmetic issue. Anyway, 2 more patches to get in...

Comment 7 Michal Skrivanek 2019-02-22 11:33:07 UTC
oh, and Instance Types are not version specific, so technically it should be still there

Comment 8 meital avital 2019-03-06 13:46:01 UTC
Verified on: 4.3.2-0.1.el7

Comment 9 Sandro Bonazzola 2019-03-13 16:39:33 UTC
This bugzilla is included in oVirt 4.3.1 release, published on February 28th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.