Bug 1656065 - Non intuitive provisioning predictable IPs procedure (OSP-13)
Summary: Non intuitive provisioning predictable IPs procedure (OSP-13)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: z5
: 13.0 (Queens)
Assignee: Harald Jensås
QA Contact: Alistair Tonner
URL:
Whiteboard:
Depends On: 1653684
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-04 15:19 UTC by Bob Fournier
Modified: 2019-03-14 13:55 UTC (History)
8 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.2.0-4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1653684
Environment:
Last Closed: 2019-03-14 13:55:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 620391 None None None 2018-12-04 15:19:37 UTC
OpenStack gerrit 622356 None None None 2018-12-10 14:17:22 UTC
Red Hat Knowledge Base (Solution) 3732401 None None None 2018-12-04 15:19:37 UTC
Red Hat Product Errata RHBA-2019:0448 None None None 2019-03-14 13:55:18 UTC

Description Bob Fournier 2018-12-04 15:19:37 UTC
+++ This bug was initially created as a clone of Bug #1653684 +++

Description of problem:

To make the provisioning IPs work for the compute nodes, one should either:

* Use the deprecated NovaComputeIPs parameter
or
* Have a custom role file and comment out "deprecated_param_ips: 'NovaComputeIPs'"

When using the default and recommended way i.e not using custom role file + new parameters (ComputeIPs) the computes don't get the predictables IPs on the provisioning network (work for the rest of the networks).

This is not intuitive and should be either fixed (best option) or explicitly mentioned in the docs.

Version-Release number of selected component (if applicable):

14

How reproducible:

always

Steps to Reproduce:
1.
  ComputeIPs:
    internal_api:
    - 172.17.1.211
    - 172.17.1.212
    storage:
    - 172.17.3.211
    - 172.17.3.212
    tenant:
    - 172.17.2.211
    - 172.17.2.212
    ctlplane:
    - 172.16.0.131
    - 172.16.0.132

2. Deploy
3. 

Actual results:

Computes nodes get ips from the dhcp pool
 openstack server list -c Name -c Networks | grep compute
| lab-compute01    | ctlplane=172.16.0.32 |
| lab-compute02    | ctlplane=172.16.0.28 |

Expected results:

 openstack server list -c Name -c Networks | grep compute
| lab-compute01    | ctlplane=172.16.0.131 |
| lab-compute02    | ctlplane=172.16.0.132 |


Additional info:

Using NovaComputeIPs or commenting this line in the compute role
deprecated_param_ips: 'NovaComputeIPs'

Works, computes get the right IPs

--- Additional comment from Harald Jensås on 2018-11-27 07:27:13 EST ---

Also, if the end user us the tooling to generate a custom roles data file based on the samples we provide, they still end up with the deprecated names:
  https://github.com/openstack/tripleo-heat-templates/blob/master/roles/Compute.yaml#L18-L24

We need the deprecated names in tripleo-heat-templates/roles_data.yaml for users upgrading environments that did'nt specify roles data.

--- Additional comment from Gregory Charot on 2018-11-29 03:47:03 EST ---

tested https://review.openstack.org/620391

Works with NovaComputeIPs and ComputeIPs.

Thx for the quick fix

--- Additional comment from Keigo Noha on 2018-12-03 20:26:46 EST ---

Hello Harald,

Thank you for your work on this bugzilla.
I have a user who faced this issue. Could you consider to backport the fix into RHOSP13 once the proposed fix is merged in upstream?

Best Regards,
Keigo Noha

Comment 5 Gregory Charot 2018-12-19 12:37:37 UTC
Predictable IPs are indeed GA in OSP13 but not for the provisioning network. See comment from PM on the RFE BZ
https://bugzilla.redhat.com/show_bug.cgi?id=1337770#c32

Comment 6 Keigo Noha 2019-01-24 01:47:05 UTC
Hi Gregory,

The document doesn't restrict the predictable IPs can not be used for the provisioning network. It just describes an example to use it.

Hi Ramon,

Could you please clarify the support status of predictable IPs for each network?
The current doc just describes an example and users expect that the feature can be usable to other networks, e.g. provisioning network.

Best Regards,
Keigo Noha

Comment 7 Bob Fournier 2019-01-24 13:41:12 UTC
We did backport the support for predictable IPs on the provisioning network into 13z2, see https://bugzilla.redhat.com/show_bug.cgi?id=1585958.

Comment 8 Keigo Noha 2019-01-31 07:15:27 UTC
Hi Bob,

Thank you for your clarification. We're waiting for the release of RHOSP13z5.

Regards,
Keigo

Comment 10 Bob Fournier 2019-02-07 12:32:26 UTC
Keigo - the builds are currently being done for 13z5, when the build is ready the FIV will be set.  When 13z5 is available this bug will be marked CLOSEED/ERRATA and the pkg will be available.

Comment 11 Keigo Noha 2019-02-18 08:22:30 UTC
Hi Bob,

Thank you for your update. The status of this bugzilla is still POST status. Would you please check whether this fix is included in the package under QA?

Regards,
Keigo Noha

Comment 14 errata-xmlrpc 2019-03-14 13:55:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:0448


Note You need to log in before you can comment on or make changes to this bug.