Bug 1656078 - [Module Streams] - "Filter by Status:" is not working if user tried to use pagination
Summary: [Module Streams] - "Filter by Status:" is not working if user tried to use pa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hosts - Content
Version: 6.5.0
Hardware: All
OS: All
unspecified
low vote
Target Milestone: Released
Assignee: John Mitsch
QA Contact: Stephen Wadeley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-04 15:53 UTC by Omkar Khatavkar
Modified: 2019-10-07 17:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-14 12:39:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2019:1222 None None None 2019-05-14 12:39:29 UTC
Foreman Issue Tracker 25627 None None None 2018-12-04 19:11:02 UTC

Description Omkar Khatavkar 2018-12-04 15:53:44 UTC
Description of problem:
"Filter by Status:" is not working if the user tried to use pagination 

Version-Release number of selected component (if applicable):
Satellite 6.5 Snap 6

How reproducible:
Always 

Steps to Reproduce:
1.Navigate to https://<Sathost>/content_hosts/4/module-streams?page=3&per_page=20
2.Install module stream in client host (e.g. dnf module install php)
3.On Content Host-> Module Stream Page-> Use Pagiantion e.g. naviagate to last page
4.try to use filter "Filter by Status:"

Actual results:
The Filter is not working after use of pagination 

Expected results:
The Filter should work in all cases instead of on pagination 

Additional info:

Comment 3 John Mitsch 2018-12-04 19:11:01 UTC
Created redmine issue https://projects.theforeman.org/issues/25627 from this bug

Comment 8 errata-xmlrpc 2019-05-14 12:39:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2019:1222


Note You need to log in before you can comment on or make changes to this bug.