Bug 165626 - line wrapping with national symbols broken
Summary: line wrapping with national symbols broken
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pan (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Michael A. Peters
QA Contact: Fedora Extras Quality Assurance
URL: http://lists.freebsd.org/pipermail/fr...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-08-10 21:40 UTC by Michael A. Peters
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 0.14.2.91-3.1.fc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-12 17:23:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael A. Peters 2005-08-10 21:40:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050720 Fedora/1.0.6-1.1.fc4 Firefox/1.0.6

Description of problem:
news/pan2 port badly wraps long lines if they contains national symbols (and therefore are internally represented in UTF-8)

Version-Release number of selected component (if applicable):
pan-0.14.2.91-2.1.fc4

How reproducible:
Didn't try

Steps to Reproduce:
1. I have not verified this bug yet.
2.
3.
  

Additional info:

e-mail from bug reporter:

Hello,
It seems that the version of Pan newsreader in Fedora 4 Extras has a bug
with line wrap when typing in languages other than English. It wraps
lines at column 40 approximately. I found on the web that the developers
have released a patch resolving this. Could you include this patch in
your FC4 package?
I would do it myself, but I really don't know how.

I found your email address in the pan.spec file of
pan-0.14.2.91-2.1.fc4.src.rpm and I thought you are the maintainer of
this package.

I m asking this because this usability bug affects a lot of people and
not just me.
Thank you

Comment 1 Michael A. Peters 2005-08-11 18:31:39 UTC
Here is a test rpm with patch applied

http://mpeters.us/testing/pan-0.14.2.91-3.i386.rpm

Comment 2 Rob 2005-08-11 19:44:08 UTC
It works fine. I added several keyboard layouts and tested line wrapping. I
could not reproduce the bug. Line wrapping works the same for all the languages
that I have tried.


Comment 3 Michael A. Peters 2005-09-11 11:55:12 UTC
Fixed committed in CVS, build requested


Note You need to log in before you can comment on or make changes to this bug.