Bug 1656266 - [virtio-win][balloon] balloon device hot-unplug fail if balloon service is running
Summary: [virtio-win][balloon] balloon device hot-unplug fail if balloon service is ru...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: virtio-win
Version: 8.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 8.0
Assignee: Gal Hammer
QA Contact: lijin
URL:
Whiteboard:
Depends On:
Blocks: 1659244 1721245 1725380
TreeView+ depends on / blocked
 
Reported: 2018-12-05 05:39 UTC by lijin
Modified: 2019-07-30 14:22 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1721245 (view as bug list)
Environment:
Last Closed: 2019-07-30 14:22:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2019:1997 None None None 2019-07-30 14:22:45 UTC

Description lijin 2018-12-05 05:39:37 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.boot guest with balloon device:
/usr/libexec/qemu-kvm \
    -monitor stdio  \
    -name 'avocado-vt-vm1'  \
    -sandbox off  \
    -machine q35  \
    -nodefaults \
    -device VGA,bus=pcie.0,addr=0x1 \
    -device pcie-root-port,id=pcie.0-root-port-5,slot=5,chassis=5,addr=0x5,bus=pcie.0 \
    -device qemu-xhci,id=usb1,bus=pcie.0-root-port-5,addr=0x0 \
    -device pcie-root-port,id=pcie.0-root-port-6,slot=6,chassis=6,addr=0x6,bus=pcie.0 \
    -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pcie.0-root-port-6,addr=0x0 \
    -drive id=drive_image1,if=none,snapshot=off,aio=threads,cache=none,format=qcow2,file=/home/kvm_autotest_root/images/win2019-64-virtio-scsi.qcow2 \
    -device scsi-hd,id=image1,drive=drive_image1 \
    -device pcie-root-port,id=pcie.0-root-port-7,slot=7,chassis=7,addr=0x7,bus=pcie.0 \
    -device virtio-net-pci,mac=9a:ac:ad:ae:af:b0,id=id3MOJiK,vectors=4,netdev=idAOrAbG,bus=pcie.0-root-port-7,addr=0x0  \
    -netdev tap,id=idAOrAbG,vhost=on,script=/etc/qemu-ifup \
    -m 14336  \
    -smp 24,maxcpus=24,cores=12,threads=1,sockets=2  \
    -cpu 'Skylake-Server',+kvm_pv_unhalt,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time \
    -drive id=drive_cd1,if=none,snapshot=off,aio=threads,cache=none,media=cdrom,file=/home/kvm_autotest_root/iso/windows/winutils.iso \
    -device scsi-cd,id=cd1,drive=drive_cd1 \
    -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1  \
    -vnc :1  \
    -rtc base=localtime,clock=host,driftfix=slew  \
    -boot order=cdn,once=c,menu=off,strict=off \
    -enable-kvm \
    -qmp tcp:0:4444,server,nowait \
    -device pcie-root-port,id=pcie.0-root-port-8,slot=8,chassis=8,addr=0x8,bus=pcie.0 \
    -device virtio-balloon-pci,id=balloon0,bus=pcie.0-root-port-8,addr=0x0


2.install balloon service in guest:
# blnsrv.exe -i

3.hot-unplug balloon device:
(qemu) device_del balloon0 

Actual results:
balloon device still in guests

Expected results:
balloon device can be unplug correctly.

Additional info:
1. Downgrade driver to build 154, unplug can be finished without any error, so it's a regression bug

Comment 1 lijin 2018-12-05 05:41:39 UTC
package info:
    virtio-win-prewhql-162
    kernel-4.18.0-40.el8.x86_64
    qemu-kvm-3.0.0-2.module+el8+2208+e41b12e0.x86_64
    seabios-bin-1.11.1-2.module+el8+2173+537e5cb5.noarch

Comment 2 Gal Hammer 2018-12-11 14:23:42 UTC
What are the Windows and blnsvr.exe versions? Thanks.

Comment 3 lijin 2018-12-12 03:35:11 UTC
(In reply to Gal Hammer from comment #2)
> What are the Windows and blnsvr.exe versions? Thanks.

Windows: win2019
balloon driver and blnsrv.exe:virtio-win-prewhql-162

Comment 5 Gal Hammer 2018-12-16 11:06:47 UTC
A patch was posted, waiting to see why the hck-ci fails.

Comment 7 Yan Vugenfirer 2018-12-18 09:59:57 UTC
(In reply to Gal Hammer from comment #5)
> A patch was posted, waiting to see why the hck-ci fails.

We had an issue with a test certificate.
The commit is merged with master.

Comment 8 Yan Vugenfirer 2018-12-18 10:00:31 UTC
(In reply to Gal Hammer from comment #5)
> A patch was posted, waiting to see why the hck-ci fails.

We had an issue with a test certificate.
The commit is merged with master.

Comment 15 Peixiu Hou 2019-03-05 06:41:08 UTC
Reproduced this issue with virtio-win-prewhql-162.

Verified this issue with virtio-win-prewhql-168, when balloon service is running, the balloon device can be hot-unplugged successfully.

Steps as comment#0.

Used versions:
kernel-4.18.0-70.el8.x86_64
qemu-kvm-3.1.0-11.module+el8+2747+40c9b77e.x86_64
seabios-bin-1.12.0-1.module+el8+2706+3c6581b6.noarch

Best Regards~
Peixiu

Comment 18 errata-xmlrpc 2019-07-30 14:22:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:1997


Note You need to log in before you can comment on or make changes to this bug.