Bug 1656300 - gdisk always returns error 1.
Summary: gdisk always returns error 1.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gdisk
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Nikola Forró
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-12-05 08:04 UTC by Marcin Prejsnar
Modified: 2019-08-06 12:35 UTC (History)
4 users (show)

Fixed In Version: gdisk-0.8.10-3.el7
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 12:35:26 UTC
Target Upstream Version:


Attachments (Terms of Use)
Backported upstream fix (1.31 KB, patch)
2018-12-05 10:17 UTC, Nikola Forró
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2042 0 None None None 2019-08-06 12:35:27 UTC

Description Marcin Prejsnar 2018-12-05 08:04:09 UTC
Description of problem:


Version-Release number of selected component (if applicable): 0.8.10-2.el7.x86_64


How reproducible: Alays.


Steps to Reproduce:
1. Run program interactively.
2. End with or without write changes.
3. Check exit status.

Actual results: Exit 1


Expected results: Exit 0 if no error.


Additional info: Version 0.8.6 from RH 7.5 worked fine.

Comment 2 Nikola Forró 2018-12-05 10:17:47 UTC
Created attachment 1511611 [details]
Backported upstream fix

Comment 7 Bohdan Milar 2019-04-03 14:19:05 UTC
Tested to verify the bugfix.

gdisk-0.8.10-2.el7:
# gdisk /dev/sda
...
Command (? for help): q
# echo $?
1

gdisk-0.8.10-3.el7:
# gdisk /dev/sda
...
Command (? for help): q
# echo $?
0

New version returns 0 after quit correctly.
Bugfix verified.

Comment 10 errata-xmlrpc 2019-08-06 12:35:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2042


Note You need to log in before you can comment on or make changes to this bug.