Bug 165633 - kernel ignores boot option quiet
kernel ignores boot option quiet
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-08-10 18:39 EDT by Paul Dickson
Modified: 2015-01-04 17:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-30 21:57:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg for kernel-2.6.12-1.1469_FC5 (15.92 KB, text/plain)
2005-08-12 17:12 EDT, Paul Dickson
no flags Details

  None (edit)
Description Paul Dickson 2005-08-10 18:39:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050802 Firefox/1.0+

Description of problem:
Kernels 2.6.12-1.1469_FC5 and 2.6.12-1.1464_FC5 ignore the boot option quiet.  Even though the dmesg output contains the quiet option in the kernel command line, the full text of the kernel boot is outputted to the screen.

This works as it should in kernel-2.6.12-1.1456_FC5 and before.

Version-Release number of selected component (if applicable):
kernel-2.6.12-1.1469_FC5

How reproducible:
Always

Steps to Reproduce:
1. Grub has the following kernel line:
    kernel /vmlinuz-2.6.12-1.1469_FC5 ro root=LABEL=/ hda=none rhgb quiet
2. Boot kernel

  

Actual Results:  Kernel boot text scolls by as though the quiet option wasn't given.

Expected Results:  No kernel boot text should appear.

Additional info:

$ cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 1.60GHz
stepping        : 8
cpu MHz         : 798.089
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe nx est tm2
bogomips        : 1598.36
Comment 1 Dan Carpenter 2005-08-10 23:42:42 EDT
Could you also paste the output from `cat /proc/cmdline`?  

Thanks so much.
Comment 2 Paul Dickson 2005-08-12 13:56:08 EDT
$ cat /proc/cmdline
ro root=LABEL=/ hda=none rhgb quiet
Comment 3 Dan Carpenter 2005-08-12 16:31:33 EDT
Thanks.  

I looked through the code and it's basically a two liner in init/main.c
quiet_kernel().  It hasn't changed recently.

It just sets the first number in `cat /proc/sys/kernel/printk` to 4.  What's the
output from `cat /proc/sys/kernel/printk` on your system?

Also could you post the attach your dmesg output?

One possibility is that there is a driver doing printks at a WARN level.

Comment 4 Paul Dickson 2005-08-12 17:12:55 EDT
Created attachment 117692 [details]
Dmesg for kernel-2.6.12-1.1469_FC5

$ cat /proc/sys/kernel/printk
6	4	1	7
Comment 5 Paul Dickson 2005-08-13 04:48:13 EDT
This seems to be a parsing problem of the kernel cmdline.

The grub kernel line:
  kernel /vmlinuz-2.6.12-1.1469_FC5 ro root=LABEL=/ hda=none rhgb quiet
results in the kernel cmdline:
  ro root=LABEL=/ hda=none rhgb quiet

So I changed the args with this table of results:
  ro root=LABEL=/ hda=none rhgb quiet     - lots of logging
  ro root=LABEL=/ hda=none rhgb quiet s   - no logging, normal boot (!)   
  ro root=LABEL=/ s hda=none rhgb quiet   - lots of logging, single user
  ro root=LABEL=/ s hda=none rhgb quiet fooobar - no logging, single user
  ro root=LABEL=/ hda=none rhgb quiet fooobar - no logging, normal boot

Now I need to go back to 1456 and test whether hda=none causes the same problem.
Comment 6 Paul Dickson 2005-08-13 05:26:43 EDT
Correction to the above:
  ro root=LABEL=/ hda=none rhgb quiet s
This behaves as it should.

So basicly, if the cmdline ends with "quiet", it gets ignored.

I have not tried rotating the arguments to see what effect this has.  It's a bit
tedious rebooting over and over, especially if the system comes all the way up.

1456 does not have this problem.
Comment 7 Dan Carpenter 2005-08-13 05:47:24 EDT
The problem is this patch linux-2.6-modules-ignore-whitespace.patch

The old code executed the checked *args then got a new param.  The new code gets
a new param and then checks *args.

Comment 8 Dan Carpenter 2005-08-13 06:18:59 EDT
I really should have read the comment that goes with that patch.  Perhaps the
correct thing is to modify next_arg() to chew any trailing white spaces.  I'm
not sure.

The point is that next_arg() returns NULL for the last argument in the list
unless there is trailing white space.

Comment 9 Dave Jones 2005-08-26 00:53:12 EDT
this should be fixed now ?
Comment 10 Paul Dickson 2005-08-30 16:05:49 EDT
I haven't seen the problem in 1504, 1511, nor 1526.

Note You need to log in before you can comment on or make changes to this bug.